Danalock -> LOCK TURN DEGEES is not working?


I am quite new in the whole automation stuff, but have allready some success with it.

Now i want to include my DANA LOCK. After a few fails i got it paired (secured) and it reacts very good on HA. Now i want to adjust two things:

-Distance in degrees for lock to unlock
-Start point (locked or unlocked start point)

For the “-Distance in degrees for lock to unlock” there is LOCK TURN DEGREES.

HELP: Factor 10 turn degree( 1 = degrees, 9 = 90 degres, etc. )
Means 1 is 10 degrees and 10 is 100 degrees.

doesn’t matter what i put in here, the lock turns only a very short way. Only around 5 degrees. Has anyone the same Problem?? If i switch on the function ASYNC, he ll make an hole 360 degrees tun. i don’t know, but this function should not have anything to do with the degrees…

-How can i adjust the start point? There is only a possibility to change the way in degrees, but not anything to set the start point.

PLEASE i need help :slight_smile:

You have to configure this setting only once.
You can do this through the app on your android/iphone.
Or you can do this through the open-z-wave control panel.

hope this helps.

1 Like

Ahhh ok! The main issue was to adjust at first the DanaLock with the phone and pair it then with the Z-wave. Then u cannot set up anything in Z-wave, but in the App over bluetooth. Its not possible to pair the DanaLock with a phone after you paired it with an Z-wave device.

The configuration with the OpenZWave Control Panel is not really possible. Adjust the turn direction and distance is does not take an effect to the DanaLock. Tried it now for hours :slight_smile:


I have other experiences.

First I paired with my phone and afterwards with my z-wave network.
I was able to change parameters through zwave.

so bluetooth/zwave combo is work nice.

I have adjusted it once or twice only.

what you need to do to update settings is the following:
in hass change the settings
wake up the lock by pressing the unlock/lock button until it beeps 2 times.

Also new att HA.
I have tried to include my Danalock in HA.
It shows up in HA but I can not lock or unlock it.
It just bounces back from the position its at when trying to change it and nothing happens with the lock.

I have a Aeotec Z-wave stick and a Raspberry 3.
Pairing with other devices works fine.

I paired it in HA and chosed secure.
Are there anything else I have missed to do?

Thanks for any help :slight_smile: !

Glad to hear the Danalock works well with HA!

Question, are either of you in the US, and do you have Mortise locks?
(Mortise lock being the deadbolt and handle integrated into one lock that fits inside hollowed out mortise space in door.)

I am in the US and most apartments here use this style of lock rather than a dedicated deadbolt.

You need to add the lock as a zwave secure device and add a network security key to your hass and ozwcp config.

Indeed danalock just works fine. Make all config of rotation and stuff with the app and after pair it with zwave

Thanks. Got it to work fine now.
Have tried Domoticz before.
Didnt have to change anything there, just do the secure inclusion.

But now it is working :slight_smile: in HA.
Just starting to use HA instead of Domoticz.
Thought I give it a try. I dont like Domoticz to much.

Silly question…I also have the same issue. Deleting keys and factory reset doesn’t help.tze lock just won’t turn and I also can’t set degrees. It just won’t change anything. Also manually with the button turns the lock just a few degrees…did u get rid of this problem?