Danalock Zigbee, Smartthings only way to go?

Tags: #<Tag:0x00007f77fc786ad8>

Hi,
Purchased a Danalock V3 Zigbee. Might have been a bit too early though, not much support in home assistant so far.
My question is simply, is Smartthings hub the only way to go at this stage if I want full functionality for the Danalock?
Have a Conbee II on hassio which works fine with my other stuff.
There are some tweaks available on this forum but with warnings that it might ruin other functionality.

I’ve got the Zigbee version lock too yesterday. I wonder why people mostly get z-wave?
Anyhow, currently I’m deciding on the gateway too since bluetooth seems to be a pain. I’m choosing between Smartthings and Zigbee2MQTT.

It seems silly to buy Smartthings hub only for this purpose, and Zigbee2MQTT dongle has to be connected to at least a Rapsberry which needs to be put somewhere next to my entrance door… and it seems silly too in my setup.

So I guess I’m saying that you’re not alone.

Thanks for feedback. I actually went for the Smartthings hub.
Works without issues and when/if HomeAssistant and Danalock integration is in place I might sell the Smarthub.
In retrospect I perhaps should have gone with the Smarthub instead of the Conbee II from the beginning but I heard so much talk about Smartthings being cumbersome to setup with Xiaomi devices (which is quite simple with the Conbee)

I decided to give Zigbee2MQTT a go. It’s unlikely I’ll find use for Smartthings hub except for Danalock in the near future. So we’ll see how that goes :slight_smile:

Did you finally choose Smartthings or Zigbee2MQTT? I have Danalock V3 and Zigbee2MQTT and I am having an issue when the lock cannot be lock (i.e. if I forgot to lift the handle) as the lock is anyway sending “lock” status through zigbee, and it should send something different (“lock_error” or “unlock”), so Home Assistant is not aware if the door is locked or unlocked. Can you check if you are having the same issue with your lock by any chance?

Hi. It seems I’m far behind you on this. So won’t be able to help unfortunately. I went with Z2M too but I failed miserably with connecting Danalock to the network. Well, it connects and even responds to the first 1-2 commands but then something happens and I keep getting “no network route” error. I believe it’s because of the zigbee implementation in the lock and it seems something is messed up with routing in there so I gave up…

Do you have repeaters in your zigbee network or just a coordinator? If you have repeaters you may want to disconnect them while you try to setup the danalock, and if you don´t maybe it was just a firmware issue at the time you tried to link it.

If you want to give it another try, my advise would be to remove the device from the network (using zigbee2mqtt/bridge/config/remove or zigbee2mqtt/bridge/config/force_remove if the normal remove doesn´t work as explained here: https://www.zigbee2mqtt.io/information/mqtt_topics_and_message_structure.html) and then add it again.

I had some issues at the beginning and I solved them following these steps:

  1. Remove the device from zigbee network
  2. Upgrade danalock to latest firmware (using the mobile app)
  3. Calibrate the danalock (using the mobile app)
  4. Link the danalock to the zigbee network again

Thanks @heisenberg. I do have a bunch of routers and the coordinator is on the 2nd floor of the house, so signal strength (even though I’m using CC1352P-2) apparently is not great (right now it shows 51 lqi though). I tried disconnecting the routers, Danalock connects, but after 30-40 minutes (zigbee network routing rebuild time as per z2m docs I think) I start getting “no network route” errors operating it. Because of Danalock I even put one of the routers 2.5m away from it but that didn’t help. I even tried bringing the coordinator to the lock and pairing that way but it produced the same result.

But I decided to try again and followed your advice (especially since new firmware was available) and now I’m getting different errors:

zigbee2mqtt:error 2020-05-22 18:01:26: Publish 'set' 'state' to 'front_door_lock' failed: 'Error: Command 0x000b57fffe59d648/1 closuresDoorLock.lockDoor({"pincodevalue":""}, {"timeout":10000,"manufacturerCode":null,"disableDefaultResponse":true}) failed (Error: Timeout - 27264 - 1 - 53 - 257 - 0 after 10000ms)'

Did you experience something like this before?

No, I never got that type of error, and I have deleted and added the danalock from the zigbee network couple of times (trying to fix the issue I mentioned before), and every time I add it the device is recognized straight away without any issue, is your Danalock V3 or different version? do you have the latest version of zigbee2mqtt and Home Assistant? If everything is up to date and this is the only device that is causing you issues, I would say there must be some data still there after you remove the device from the network, maybe you can try to remove it completely (removing it from the network and then removing it manually from the Devices list and Entity list) and then rebooting zigbee2mqtt and HA and start from the beginning adding it to the network again.

After some testing I got the error you mentioned (no network route) couple of times, but it is pretty random. It looks like the lock is disconnected from the zigbee network, but I need to do more testing to see if I can find the origin of the problem and fix it

I have V3 too and latest versions of everything, yes. Nothing is left when I remove DanaLock from HA, and I don’t think it’s HA that is the problem since it’s not on Z2M network. And since it’s indeed the only device in the network of 28 or so, I do believe something is wrong with the lock itself. I’ll contact the manufacturer and see if they can help in any way, will report here when I have any news.