Danfoss Ally orientation attribute 4014

I’ve just wanted to share my discovery on Danfoss Ally TRV.
My TRVs are placed very bad, in the corner of the room between wall and radiator. So I already had +25 setpoint offset and in cold days that was not enough. Besides, TRV was recording high temperatures right after opening the valve. I had a standard setting for TRV mounted horizontally which is default. This is set at custom attribute 4014 on cluster 0201. Yesterday I was experimenting with other settings and decided to give a try for trv vertical orientation. And that was it! Ally has some internal algorithm for vertical mount! This mount means that trv is very close to radiator and is very much influenced by its heat. And setting this mount type is switching some internal algorithm for temperature measurements. If your trv is covered and struggling with setting right temperatures, try vertical mount setting and please report on your findings. Just let me warn you that if your trv has no issues with heat coming from radiator, this setting is not for you! I have one trv mounted correctly with proper positioning vs wall and radiator and setting vertical mount for this one completely falsified the temperatures readings by 4 degrees. I’m using deconz to set this. Don’t know how to set this with zha or z2m. Maybe others can help.

1 Like

does this still work for you ?

yes. I can confirm firmware 1.18 has it and it works the same. To see the effect, you need to close the trv for a few hours (like during the night). Then set trv to some high temperatures. It’ll open valve and with default orientation you probably almost instantly will see the heat rising temperature reported by the ally. With vertical orientation reported temperature first will go down a bit - this is where this changed algorithm kicks in. Hope this helps.

1 Like

where / how do you set This custom attribute 4014 on cluster 0201 ?

I’m using deconz for this

But after a week on firmware 1.18 don’t bother with this. Just use “Radiator covered” attribute with external room sensor. Works like a charm as described.

so I only have to change this to true ?


yes. Set Radiator covered to true and then you need to push room temperature to trv every 0,1C change, not more often than every 5 minutes and not less often than every 35minutes.

So glad I found your post… I was having a crazy time with several of my danfoss allies until i set them in zigbee2mqtt to vertical orientation (true). it could be because there’s a concrete window sill above them and the TRV is parallel (placed close along the width) to the radiator rather than perpendicular, if that makes any sense. This is with TRVs set as uncovered.