Darksky sensor high temp not working

I’m new to hassio, and despite being a professional developer, am having a hard time with what looks like simple stuff. I finally got some weather stuff working and my automations/scripts work with the current temp given by dark sky, but not the high of the day. My sensors up top include the current temp, but not the high.


          - temperature
          - temperature_high
        update_interval: 600
          - 0


        friendly_name: Current Temp
        friendly_name: Today's High # <- not working

In my automations, if I replace the entity with ‘sensor.dark_sky_temperature’ it works fine.

    - service: persistent_notification.create
          message: "Temp = {{ states('sensor.dark_sky_daytime_high_temperature') | float }}"
          title: "Debugging"

EDIT: Solved! Step 1: Update hassio. Step 2: Suffix with _0d

Did you check in dev-tools to see if that entity exists? (hint it doesn’t)
Try sensor.dark_sky_daytime_high_temperature_0d

You’re right that it didn’t exist. I updated my customize and my automation files to use sensor.dark_sky_daytime_high_temperature_0d and nothing changed. Still not visible in the dev-state list. Perhaps because I haven’t updated in forever and I’m still on 0.85.1?

May I ask, where in the documentation is the “_0d” suffix listed?

It was in the release notes for a recent Home Assistant version. The created sensors aren’t listed in the docs for dark-sky so it’s not an error. You should always get in the habit of checking the entity names in dev-tools whenever you create a new sensor to confirm the name and if you ever see errors like here, that’s your best quickest option to find out why.

If you changed it and it’s not showing then there is an error in your edits. (eg I trust you didn’t change the monitored conditions as they didn’t change - only the created sensor)

Correct, I did not change the monitored conditions.

It’s still not working and I assume that’s because I’m way out of date. Unfortunately, I’m having trouble updating, but that’s a separate issue.

Updated, everything works. Finally. I really need to fix my DNS settings.

1 Like