Darksky sensor not working in hassio 0.86.4

Initially, I added darksky to my config.yaml and Lovelace UI. I’ve changed my approach and decided to use the darksky sensor to integrate the outside temp into a graph with my inside temperatures. Hassio does not see the sensors and I have nothing in the log related to darksky. I’ve tried refreshing the api key without success.

My config.yaml is
# Getting weather conditions from the web for the GPS location defined above.
- platform: darksky
api_key: xxxx
name: “Outside”
- temperature
- humidity

whooo hooo figured one out all by myself!
It turns out that by updating Hassio, I solved the problem. Prior to the screen shot below, I was at V1.? Note that home assistant was already running at it’s latest version - see second screen shot. Perhaps I’m ignorant should I update both HomeAssistant and Hass.io separately?

HassOS is the underlying operating system and is totally separate from Home Assistant. They get updated separately as well.

1 Like

Thanks- I understood that concept generally but not in working practice. This might be a reason that new users fight bugs… I’ve noticed a few other things that were not working as described in the help files suddenly corrected.

It generally should make no difference. Home Assistant is agnostic about the underlying OS… The underlying OS could be anything (Raspbian, Debian, Ubuntu etc) But it’s a good idea to keep updated anyway.

I’m surprised you fixed the error by updating the OS to be honest… that would be rare… more like a coincidence…

I certainly take your point and don’t debate it.

I should mention (in case this helps in any way) This HA install is about 1 week old - meaning that I was having so many problems that I re-downloaded HA and re-imaged the SD card. I manually entered everything into my config files (to learn and to avoid any chance of corrupting things) So my point here is that by updating HassOS my issues went away.

what version of HA were you running prior to “updating”?

HA has always been 0.86 in my troubleshooting of darksky.
Hass.io, which came bundled with HA was not at it’s latest, If I remember, perhaps 1.7.

To be clear, from here: https://www.home-assistant.io/hassio/installation/ I downloaded the “Raspberry Pi 3 model B and B+ 32bit” version which includes the old version of Hassio.

Ok, I should have clarified better. What version of HA did you originally start with when you started home assistant?

Somehow i corrupted my SD card while learning Lovelace. Last weekend, I completely started over and installed HA using the link above- so my comments are all based on a fresh install from 1 week ago. I did not restore from a backup and I manually re-created my config.yaml and ui-lovelace.yaml as my setup is pretty simple and recreating is helping me to understand everything better.

I did have HA running on this PI / SD card previously- to answer your question - though I would expect that re-imaging the card would have taken anything out from that state. I think I was 0.84 ish?