DarkSky temperature high/low sensors are not working


#1

Hi guys,

I’m trying to setup the DarkSky sensors and I’m using this in my config:

  - platform: darksky
    api_key: 
    monitored_conditions:
      - summary
      - precip_type
      - precip_intensity
      - precip_probability
      - precip_accumulation
      - temperature
      - apparent_temperature
      - dew_point
      - wind_speed
      - wind_bearing
      - cloud_cover
      - humidity
      - pressure
      - visibility
      - ozone
      - minutely_summary
      - hourly_summary
      - daily_summary
      - temperature_high
      - temperature_low
      - apparent_temperature_high
      - apparent_temperature_low
      - precip_intensity_max
      - uv_index

And my sensors:

weather_temperature:
  name: "Temperature"
  entities:
    - sensor.dark_sky_temperature
    - sensor.dark_sky_temperature_high
    - sensor.dark_sky_temperature_low
    - sensor.dark_sky_apparent_temperature
    - sensor.dark_sky_apparent_temperature_high
    - sensor.dark_sky_apparent_temperature_low

but for some reason those sensors aren’t showing, log files say nothing about those sensors, yet they don’t show up on my dashboard. This applies for dark_sky_temperature_high, dark_sky_apparent_temperature, dark_sky_apparent_temperature_high and dark_sky_apparent_temperature_low.

I’m I using the wrong syntax for those?


#2

high is daytime_high_temperature
low is overnight_low_temperature


#3

Are you sure? I can’t really make that out from the code here or docs here.


#4

Yes
sensor.dark_sky_daytime_high_temperature
sensor.dark_sky_overnight_low_temperature

With those monitored conditions, if you look in the dev tools > states you will see all the darksky sensors it creates


#5

Interesting! I does work yes!

Updated my config to:

weather_temperature:
  name: "Temperature"
  entities:
    - sensor.dark_sky_temperature
    - sensor.dark_sky_daytime_high_temperature
    - sensor.dark_sky_overnight_low_temperature
    - sensor.dark_sky_apparent_temperature
    - sensor.dark_sky_apparent_temperature_high
    - sensor.dark_sky_apparent_temperature_low
    - sensor.dark_sky_daytime_high_apparent_temperature
    - sensor.dark_sky_overnight_low_apparent_temperature

And they show now, thanks!


#6

Running .83.2, I’ve stopped getting high and low temps. I was using temperature_high/temperature_low for monitored_conditions.

As recommended above, I tried daytime_high_temperature/overnight_low_temperature but that causes an error in HA saying that those are invalid conditions.

Is anyone using .83.2 and still getting highs/lows? Didn’t see anything in breaking changes.


#7

I had the same issues. With guidance from another user here, I modified my .yaml files as follows:
sensors.yaml:

#######################################
# Weather
#-|---|---|---|---|---|---|---|---|---|

- platform: darksky
  name: Galveston
  api_key: !secret darksky_api
  latitude: 29.300130
  longitude: -94.795850
  update_interval: "00:15"
  forecast:
    - 0
  monitored_conditions:
    - hourly_summary
    - temperature
    - temperature_high
    - temperature_low
    - apparent_temperature
    - cloud_cover
    - precip_type
    - precip_probability
    - precip_intensity
    - wind_speed
    - wind_bearing
    - wind_gust
    - humidity
    - dew_point
    - uv_index
    - visibility
    - ozone
    - pressure
    - nearest_storm_distance
    - nearest_storm_bearing

ui-lovelace.yaml

  - type: vertical-stack
    cards:
      - type: entities
        title: Island Weather Conditions
        show_header_toggle: false
        entities:
          - type: divider
          - type: entity
            name: ' '
            entity: sensor.galveston_hourly_summary
          - type: divider
          - type: entity
            name: Temperature
            entity: sensor.galveston_temperature
          - type: entity
            name: Overnight Low
            entity: sensor.galveston_overnight_low_temperature_0
          - type: entity
            name: Daytime High
            entity: sensor.galveston_daytime_high_temperature_0
          - type: entity
            name: Feels Like
            entity: sensor.galveston_apparent_temperature
          - type: entity
            name: Dew Point
            entity: sensor.galveston_dew_point
          - type: entity
            name: Barometric Pressure
            entity: sensor.galveston_pressure
          - type: entity
            name: Cloud Cover
            entity: sensor.galveston_cloud_coverage
          - type: entity
            name: Rain Intensity
            entity: sensor.galveston_precip_intensity
          - type: entity
            name: Wind Speed
            entity: sensor.galveston_wind_speed
          - type: entity
            name: Wind Gusting
            entity: sensor.galveston_wind_gust
          - type: entity
            name: Wind Coming From the
            icon: mdi:compass
            entity: sensor.galveston_wind_dir
          - type: entity
            name: Nearest Storm
            entity: sensor.galveston_nearest_storm_distance
          - type: entity
            name: Nearest Storm Bearing
            icon: mdi:compass
            entity: sensor.galveston_nearest_storm_dir
          - type: entity
            name: Humidity
            entity: sensor.galveston_humidity
          - type: entity
            name: Ozone Level
            entity: sensor.galveston_ozone
          - type: entity
            name: UV Level
            entity: sensor.galveston_uv_index

note the _0 appended to the sensor entity names you used to have. The 0 throughout means today.


#8

Thanks. The “forecast” option was what I was missing. Once I added that, I started getting the highs/lows with the _0 suffix. Thanks.


#9

That was a change in 0.83 adding the 0. It pays to read the release notes!