Dashboard Error. Entity not Found/Directory Not writeable


#1

Hi all, I have installed Appdaemon through Hassbian-config and managed to get the HADashboard installed also and can view dashboards. When I open a dashboard though, it is showing it cannot connect to entities and looks to be a permissions error on the files. Any ideas how I can fix this and allow the connection to home assistant?

Blockquote2018-12-05 12:11:52.866826 INFO AppDaemon Version 3.0.2 starting
2018-12-05 12:11:52.867584 INFO Configuration read from: /home/homeassistant/appdaemon/appdaemon.yaml
2018-12-05 12:11:52.872932 INFO AppDaemon: Starting Apps
2018-12-05 12:11:52.874634 WARNING config_dir: /home exists, but is not writeable, owner: root
2018-12-05 12:11:52.883174 INFO AppDaemon: Loading Plugin HASS using class HassPlugin from module hassplugin
2018-12-05 12:11:53.073621 INFO AppDaemon: HASS: HASS Plugin Initializing
2018-12-05 12:11:53.074894 INFO AppDaemon: HASS: HASS Plugin initialization complete
2018-12-05 12:11:53.076045 INFO Starting Dashboards
2018-12-05 12:11:53.079425 WARNING css: /home exists, but is not writeable, owner: root
2018-12-05 12:11:53.082225 WARNING javascript: /home exists, but is not writeable, owner: root
2018-12-05 12:11:53.097184 INFO API is disabled
2018-12-05 12:11:53.158544 WARNING AppDaemon: HASS: Disconnected from Home Assistant, retrying in 5 seconds
2018-12-05 12:11:54.266061 INFO HADashboard: New dashboard connected: Main Panel
2018-12-05 12:11:58.262206 WARNING AppDaemon: HASS: Disconnected from Home Assistant, retrying in 5 seconds


#2

Below is my appdaemon.yaml also

  logfile: /home/homeassistant/appdaemon/appdaemon.log
  errorfile: /home/homeassistant/appdaemon/appdaemonerr.log
appdaemon:
  disable_apps: 1
  threads: 10
  plugins:
    HASS:
      type: hass
      ha_url: https://xxxx.duckdns.org:8123
      token: secret
      cert_path: secret
hadashboard:
  dash_url: http://secret:5050
  dash_dir: /home/homeassistant/.homeassistant/config/appdaemon/dashboards```

#3

AD seems to have problems connecting to HA.
the most locigal option i see it that you didnt set the option:

cert_verify: True

certpath is not an option from a plugin, so you can remove that.

but i need to warn you.
you got duckdns and certification inside home assistant.
which will work if you dont want to use stuff like a dashboard.
but if you want to use a dashboard (and maybe in the future apps) you dont want that to be dependable on the internet.
besides that you will get browser problems because connecting from https to another https always gives trouble.

i strongly advice you to remove certificates and duckdns from HA and install a proxyserver for that (nginx, caddy, etc)


#4

@ReneTode I added the cert_verify line to my appdaemon.yaml file and it connected to my home assistant.

I am not following however your warning that duckdns inside of home assistant will not work with a dashboard. Once I added that line of code to my appdaemon.yaml, all my sensors work and I am able to use the dashboard with my home assistant running the duckdns. I guess this part isn’t a big deal since you provided a solution, but I was trying to more understand your logic and the idea my home assistant running better with a proxyserver. Always open to improving the setup if you have a good resource that talks on the proxyserver setup.


#5

hadashboard is a webserver and homeassistant is also a webserver.
if you open a dashboard it will be like:
http://secret:5050/dashboard

in the javascript code from that website the dashboard will need to retrieve stuff from the homeassistant server.
so it needs to use https.
most browsers dont allow redirecting to a protected website from a none protected website (or even at all) for some elements.
so you probably will get in trouble as soon as you want to use a webcam view.

with duckdns and ssl inside your homeassistant you also cannot connect to your homeassistant when the internet is down.
when the internet is dow you cannot reach the dns server (duckdns) so your dashboard wont work anymore.
even more, you cannot reach homeassistant in any way, so you cant stop, start automations, you cant do anything.

do you really want it that your homeassistant isnt reachable when you got no internet?
i dont think so.

thats why working with a proxy server is better.
its like creating a frontdoor and you can keep all doors and windows open behind that for easy access, as long as your front door is closed.

without that special frontdoor its like always needing to go through the garden if you want to go from the livingroom to the bedroom.


#6

@ReneTode Ahh, that explanation was much easier to understand. Thanks for taking the time to explain in a simple manner. I will be checking out how to setup this proxy server instead of the current.


#7

im always happy to say it with other words.
never hesitate to ask again if my first explanation isnt making things clear.

glad you understood, and im happy to help you if you need more assistance.