Dashboard is showing the yaml file name, even though node has same name

I read the other post about this “issue” as I am having a similar issue but my YAML is the exact name of my node. Not really a problem but I’d like to know the cause and fix it; if for nothing else besides my striving for tidiness. see image

Rename again. I seem to remember that finally worked for me. It will be listed under the three dots

1 Like

from Imgflip Meme Generator

1 Like

It’s night here and I can’t sleep!

nice one, I got the same issue, and renaming twice fixed it, unfortunately it also required 2 build/uploads.

could this happen when you rename the file in file explorer or vscode instead of the esphome dashboard?

I had this for a few of my devices, but one more important thing to mention.
if your file is called device.yaml
and you click remame and it says prefix-device.yaml and you immediately rename is to device.yaml which you can do at that point, it removes device.yaml (probably move to the same file fails)
so now I have to dig in to my backup to get my yaml back. :frowning:

thanks, renaming device worked.

1 Like