Dashboard would not connect to Raspberry pi server

Hi everyone,
Currently I can not get my dashboard connect to raspberry pi server. It worked almond 2 years without any major issues up until this happened. Yesterday, I accidentally turned the power off to the rpi and started this issue after I turned the power back on. All my automations are work flawlessly and I am able connect to the rpi from my phone (iOS) and windows computer. I am using Amazon fire 10” as my dashboard. Please see the attached picture regarding current issue
Thank you so much for any input

First, basic, set of questions:

  • Does your pi have a static IP address?
  • Is it possible that it is no longer
  • From the other devices, do you connect through
    a. a name like “homeassistant:8123” or
    b. in auto-discover or
    c. via the IP address?

If you can connect in ssh from “whatever device”, can you do a

netstat -an | grep 8123

That should look like
tcp 0 0* LISTEN

EDIT: basic* as I assume that you probably already tried to assess those questions

Thank you for your quick reply.
Yes I did try with “homeassistant:8123” also with ip address. I don’t have static ip on pi.

Could be a very good idea to fix the address in your router somehow, Google is your friend to find the way to do so.
Anyway, if you manage to connect in ssh, can you also do a

ip addr

That will give you the current address of your pi, like this
inet brd scope global dynamic noprefixroute wlan0

or, if you can’t connect in ssh, check your router for the list of connected devices and try to find your home assistant pi.

I am not familiar with how to do ssh connect. If you would please provide me more details. I am using Linksys router and can’t locate my server ip. I’ve connected rp directly in to the router and no luck

Did you have a look in the manual for you specific model (Linksys Official Support - User Guides, Downloads, FAQs)?
You should be able to find the dhcp leases there.

Thank you guys for helps and tips, everything works properly now