Date and Time of Hass.OS very old in Raspberry Pi 3B (solved)

Hi there,

until HA OS 9.4 everything was fine on my Raspi 3B. Automations are fine, ….
Since HA OS 9.5 the date is set to July 2022 and time ist also wrong.
Reboot doesn’t fix it.
configuration.yaml hat folgendes:

  currency: EUR
  name: homeassistant
  latitude: 53.51xxxx
  longitude: 9.67xxxx
  time_zone: Europe/Berlin

My automations doesn’t work since HA OS 9.5. So I try to find and my wife told me that lights goes on at night instead of 4PM.
I checked in Terminal (screenshot) and my Raspber6ry Pi3B ist in July 2022, but we have February 2023.

Anybody any ideas?

Is your HA connected to the Internet? Any restriction to access an external ntp server?

Take a look at this discussion as it looks quite similar to the issue you are reporting. Note that they fixed basically disabling the settings via yaml and doing it via UI, as I understood:

Hi Edward,
until HA OS 9.4 everithing fine, starting HA OS 9.5 update date on RPi3B was middle 2022.
NTP Setting not visible in HA OS.
But I found the request on “” in my pihole and cloudflare was blocked. I enable and reboot my RPi. Everything fine date & time are OK.


1 Like

I am having the same symptoms. Also RPi3B and the issue showed up after the HA OS 9.5 update.

I’m not using pihole so no blocked NTP requests that I’m aware of.

The time issue eventually resolved over night, based on log messages I think it was about 2-3 hours after the reboot. But the issue reappears after a subsequent reboot.

Have you tried to ping from command line in the terminal?
I use the Add-On Terminal&SSH.
type in “ping
If that works, your HA have access to the NTP server.

2023-02-02 10_09_36-Terminal – Home Assistant

On my side it was blocked by pihole, do you use routing or firewall in your network?

1 Like

Well now I can’t reproduce, date seems fine after a system reboot, and no problems pinging the NTP server. Earlier yesterday I was concerned maybe it was an issue with my modem/router so I also rebooted that. If I see this again I’ll try pinging the NTP server right away. Thanks.