Dear God, please help!

I have been at this all day and I’m back to square one…

My RPi 3b+ is dying and it it currently, barely, running my perpetually updated old Hassio install. I’ve managed to get it up to 0.105.5 but with every shutdown it’s taking longer and longer to come back up. I believe the SD card is dying, or maybe the power supply, I’m not sure exactly, but it’s not behaving correctly (aka as it has been for the past few years).

I have been trying to build up a replacement to transfer my configuration over to but so far I have been unsuccessful.

Here’s what I have tried:

  1. Deploy the VMDK to my VMware vSphere 6 Enterprise Plus server - NO GO - Workstation VMDK not compatible with older Enterprise version I’m running
  2. Deploy the VMware .OVA file to my VMware vSphere 6 Enterprise Plus server - Also, NO GO - “OVF descriptor too long”
  3. Installed CentOS 8 on an Lenovo ThinkCentre M72e that I have. - Check
    3a. Get Python upgraded from 3.6.x to 3.8.1 - Check (kinda) Python --version report 3.8.1 HA still uses 3.6
    3b. Work out the bugs with getting Homeassistant-pyozw installed/configured/working - Check
    3c. Discover that the version of Home Assistant that installed is capped at 0.103.6 - WTAF??? Available versions range from 0.7rc1 to 0.103.6

All I want is to have the same type of install, with all the features I have had and have used for years on hardware that is not technically a development board! Don’t get me wrong, initially I loved the idea of doing this all on a Raspberry Pi 2, then 3, then 3b, then 3b+, but I have lost quite a few 32GB & 64GB micro SD cards to these development boards and been left high and dry when they eat the cards. Backups you say, I have them, but I still have to rebuild everything and endure the bitching of my family while everything is down and the convenience of operating our home, that we’ve all become used to, changes.

If you’re still with me, thanks for hanging in there, here’s what I’m after:

  1. I want Home Assistant/Hassio/HassOS/Hasbian whatever it’s called to run on a piece of production equipment, currently my ThinkCenter M72e.
  2. I want it to run the latest version (currently 0.109.x)
  3. I want the supervisor piece with the addons for Terminal & SSG, Node-Red, and MariaDB.

I have 10x RTSP cameras, a bunch of Z-wave, even more Philips Hue, and a couple handfuls of WiFi devices outlets and power strips controlled through VeSync, Tuya, and some home-made LED floor lamps.

Can someone, anyone, for the love of GOD, please tell me how to get that?

If you can help me, I’ll find a way to buy you a beer, coffee, RedBull, Monster, pack of smokes, whatever vice keeps you running.

Thanks in advance.

Bg

(Holy sh!t, where’s the Tylenol?)

They are different things. If you want the addon options you want Home Assistant Supervised.

Could be forward compatibility issues due to this:

EDIT: actually, probably not. https://github.com/home-assistant/core/pull/29999

If you want Hass.io Home Assistant Supervised (the one that runs the add-ons) and are happy to install Ubuntu on the ThinkCenter M72e, I have a guide HERE which will get you up and running quickly.

3 Likes

I thoroughly endorse the @kanga_who howto.

Actually @kanga_who have you tried your howto on 20.04 yet?

Only because you fixed my typos :wink:

Not yet, I have a spare Dell Optiplex laying about, so I might give it a run and update as needed.

Everyone makes typos. You did the technical stuff.

Ok, just did an install on a Dell 790 USFF with Ubuntu server 20.04 LTS. Done in 25mins.

The only difference than what I have in the guide (from the official installation instructions page) is this command curl -fsSL get.docker.com | sh doesn’t work as Ubuntu 20.04 hasn’t been added to the database yet, so the docker install fails.

Instead, run these in place of the the above.

apt install docker.io
systemctl enable --now docker
usermod -aG docker SOMEUSERNAME

Everything else worked. I will make a separate 20.04 guide for the time being until 20.04 has been added to the docker install script.

1 Like

Lucky you, I can’t find the bloody power supply for my M72e and been looking for it for the last 2 hours.

I have been meaning to set it up with ubuntu and try a supervised install to replace my messy docker based nuc. But if I can’t find the power supply, we’re all doomed.

Excuse me going slightly OT here but as I have the author and the proof reader both here can I ask…

(@bg32940 in order to keep it less OT) I used this guide and it was perfect.

But my question is around Portainer. I am still a novice with Docker and Portainer and because everything ‘just works’ I haven’t had the ‘need’ to learn more about it. No excuse, but hey that’s the facts.

So, I installed Portainer as per the guide but I’m now wondering if it might have been better to just use the HA add-on if for no other reason than it would deal with upgrades without me having to worry about anything.

Is there any sense in this view and if so can you give me an idiots guide to uninstalling my Portainer before I add the add-on? Please.

1 Like

I’m glad you found it useful. :slight_smile:

You can skip that step and install via HA. I have just always installed it separately, but you’re right that it is perhaps easier to update through HA.

I’ve got an update of the guide almost ready to go using 20.04. It will be in the same Google Drive folder in the next day or so.

If you want to uninstall it…

sudo docker rm -vf portainer
sudo docker volume rm -f portainer_data

I can’t tell you the number of times it’s been handy having Portainer NOT as a HA addon… like when you do a system update and docker updates and the HA addons don’t start and you need to use ‘something’ like Portainer to get everything running again… It is VERY useful having it running via docker-compose IMO.

3 Likes

I hadn’t thought of that, great point!

@DavidFW1960. @kanga_who

Thanks, I’ll leave it as it is then.

But…

if you ever do want to remove it, then it is literally as easy as just using itself (Portainer) to delete the Portainer container. It’s the beauty of docker - no need to “uninstall” anything - just delete the individual containers and, poof, it’s gone. :wink:

Or you can do it via the command line.

Is this something that only happens when using HassOS?

IOW, does a system update when installed on a Linux Host where docker was installed separately prior to installing HA also update Docker then, too?

Exactly. It’s the same reason why I also chose to install the ssh server and samba directly in Ubuntu as opposed to using the equivalent Home Assistant add-ons. In the event docker containers fail to start, or even if the entire docker infrastructure were to fail, I still have access to the headless system via ssh and samba.

Question based on the install procedures.
My setup is similar, Ubuntu 18.04 in docker etc. I do have portainer in both HA and outside of Ha just if one fails I can use it as a fail safe.
Never thought of samba on the outside of Ha as well.
Just installed it outside of HA and works well. My PC that I use to log into HA is running Ubuntu.
How can I make samba show up automatically in my file manager program when I boot up.
I have tried cfis, fuse and a few other internet tutorials about adding to /etc/fastab, but can not get it working.
Can any one point me in a direction.
Thank you.

mount -t cifs //hamachine/share /nountpount

Yes. A system update will also update docker. Then if you had used say docker-compose and set the container to always run unless stopped it will start up again automatically. The HassOS containers are a PITA in that they seem to not restart unless you reboot.

But won’t update the containers

Correct it won’t. I use a shell script to pull new images and start them but I also use watchtower that always keeps them up-to-date.