Debian 12 (bookworm) supported?

sure sounds like it.
Try re-installing the requirements again (there’s a command line in the installer to do that)

Ok, you mean the Debian release notes. Yeah I was aware of that. Would not be an issue but symlinks where screwed up… Don’t get me wrong, I just added my notes to the thread to help others.

Hi, I am new here.
Is Debian 12 supported now?
Can I do a fresh install on a RPI4 Model B?
And then install Home assistant supervised?
Thanks in advance!

I get the same issue. Anytime the supervisor docker container restarts, it adds a route to itself for all traffic like this:

default U 0 0 0 veth393c311

As this is inserted above the real default route, it blocks the internet traffic.
So far I have been unable to find out why HA does this. If you delete the route, internet traffic will work again:

route del -net 0 veth393c311

For now, I just added a cron job (untested, I have not yet had the issue after creating this. Edit: it works):

route del -net gw netmask"

Did this happen since the last update?
Because I did that one remotely (ssh, over vpn) and rebooted after and can’t reach the machine ever since, so this could explain.

I believe this issue appeared when I updated Debian to 12.

1 Like

On a recent install, I added home assistant supervised on top of fresh bookworm image (DietPi) and lost Internet connectivity after the first step in the official script. Turned out that I had to adjust the dns server in /etc/resolv.conf back to the original as this was changed to
Hope this helps some people facing the same!

I too am having issues installing home assistant supervised on Debian 12 while following the official documentation.

When I install one of the requirements - " systemd-resolved -y " I lose internet connection and cannot progress until I disable systemd-resolved.

Once I do, I am able to completed the installation but afterwards I am left with no internet access even after restoring systemd-resolved.

On another machine I can browse to 10.X.X.X:8123 and I get the HA loading screen. DNS seems to be broken.

Is your internet still working post installation of HA? I found that systemd-resolved keeps changing /etc/resolv.conf to point to as this is a symlink file. Did you delete the symlink file and create a manual resolv.conf file?

Just commented out the name server line or changed it to the dns server I run (locally, based on pi-hole). Seems to keep working

For those who just want to upgrade from Debian 11 (bullseye) to Debian 12 (bookworm) check out my upgrade guide here. The guide is also valid for x86_64-devices.


I tried to follow the manual to upgrade my server to Debian 12. The difference is that I started from version 10.

It went smoothly until after the command - sudo apt full-upgrade -y
I got error as below.

Afterwards I couldn’t use sudo or root anymore.
I got message “account validation failure is your account locked?”
I rebooted the server but now i cannot login, and getting error message “login incorrect” after providing just username. (system doesn’t even ask for password). Same if i try in recovery option.

Do you have any suggestions where i have failed and what can I do to correct it?
Thank you!

Welcome to the forum, kaczorx2 :wave:t3:

You should really have followed the recommended upgrade flow which goes:

Debian 10 → Debian 11 → Debian 12

Going from Debian 10 directly to Debian 12 will almost certainly break the OS as it did with your installation.

Make a backup of your HA installation (if still possible), save it on another device and start all over again. Reformat the HDD/SSD/SD-Card and install Debian 12 onto a “virgin” disk.

You should also consider to use Home Assistant OS instead of HA Supervised if you are not yet secure with managing Linux. Choosing HA Supervised is considered advanced and should only be used if one is an expert in managing a Linux operating system, Docker and networking!

I need to install a reserve system. A backup from Debian11 to Debian 12 won’t work?

What kind of backup?


It is really great how much information you are providing, but backing up and restoring just works between different OS versions. Don’t understand why it wouldn’t. Then again, I don’t have an idea what kind of backup you are referring too. Good luck!

Backup from Homeassistant

As mhoogenbosch already pointed it out: Backing up and restoring just works between different OS versions.