Debugging Help - Home Assistant keeps hanging and restarting

About 2 weeks ago I had 2 updates available, one for Home Assistant Core (2023.6.3) and one for the Ring-MQTT addon (can’t remember the version but I’m pretty sure it ended in .3). As usual I said to update them, but what would happen is that it would say it was installing for a very long time (multiple minutes) then a box in the lower left would appear and say “Connection Lost. Reconnecting…” for several more minutes and then it would show that the update was unavailable

. (I’m a new forum user so can only upload one screenshot, but I have screenshots of the previous 2 states as well if needed.) After a time the update page would refresh and show the updates still needed to be installed. This went on for several days and I tried restarting Home Assistant and even the entire device a couple times. At some point, and I’m not sure when because none of the updates ever said it completed successfully, both items stopped saying there were updates and it appears that they’re both the newest versions as far as I can tell. However, since this started happening, Home Assistant will periodically hang, and I think it’s even restarting at some point, though I’m not experienced enough to say for certain. Also, trying to look at the Ring-MQTT addon’s settings will hang indefinitely. This is running a RasPi 3 using the HASSOS image and up until this, had been running fine for many months. I had recently installed the Ring-MQTT addon, but that was at least a couple weeks before this all started happening.

I’m extremely green when it comes to Home Assistant so I’m not entirely sure where to start to try to figure out what might be causing the problem, much less how to go about trying to fix it. What tools or utilities should I start with to gather data that might highlight what might be causing a problem. I don’t have a whole lot of configuration in this yet, so I guess a last resort would be to just wipe and start fresh, but I’d like to avoid that and learn how to troubleshoot so when this does become my default smart home controller, I know how to try and fix it.

As of a day or two ago, now HASS won’t start at all. In the lower left it continues to say “Starting MQTT, not everything will be available until it is finished.” and that never seems to go away. I’ve tried reloading HASS and the same thing happens when it comes back. It’s seeming more and more that I’ll need to completely blow away the HASS install and start fresh.

Try to check your logbook…Any info in there?
Maybe delete the MQTT add-on and re-install

The logbook doesn’t seem to have any relevant info in it. I removed the MQTT service and restarted the server, but it still shows the error. I think maybe the Ring MQTT addon might be the culprit, but the addon option is no longer in the Settings page so I’m not sure how I can try removing it. Is there a direct link I can use to get to addons or some other backdoor way to get to being able to remove it (SSH or CLI or something)?

I see the add on option in your screenshot. Yellow icon…

That was the case then, now, it’s no longer showing:

I just decided to reinstall HASS from scratch since things were only getting wonkier.

1 Like