deCONZ addon , where are the configuration files stored

My pi3 which had deCONZ (NOT in HASSIO) standalone does not boot anymore. I forgot to do a backup from tthe PHOSCON app, but I should be able to locate the files, that should be under

Now I installed the deCONZ official HASSIO addon, and wish to put the above configurtion file in the correct place.

Where is the HASSIO ADDON directory where to put the configuration files?


1 Like

Did you solve that problem? I’m facing the exact same issue right now.

no unfortunately, I re-paired everything

I ran into the same issue. I did find the folder, but after copying the contents over my HASS stopped working and doesn’t boot anymore; the file system was set to read only so I’m going to attempt to repair it with fsck.

In an earlier instance, I did notice that many devices automatically came back if you set deConz to allow joining. They know the ID of my RaspBee and checked back in when it came back online.

So just go to deconz and open up the joining process (be aware: security risk), and eventually most devices will repopulate.

I think more people than me would be interested in knowing the location and process for transferring a standalone deconz installation to the home assistant supervised add-on.

do you recall where you found the folder? I’ve been searching via the ssh terminal but can’t find it.

1 Like

Hopefully I’m not answering the wrong question, but as people are still asking for updates I’ll post how I solved it and hopefully it helps. I just successfully transferred a external deconz install to the add-on deconz.

My Deconz was still working, so I’m not sure how to do this if it’s broken and you can’t access it trough Phoscon.

But if you can access it trough Phoscon, here are the steps

Open Phoscon and export a backup (Phoscon → Gateway → Backup Options), then import it inside your HA Deconz add-on.

Then log in with ssh (the normal ssh not the dev one) and edit ~/config/.storage/core.config_entries, find deconz and replace the IP and port in the data field with so it looked like this

"data": {
    "host": "core-deconz",
    "port": 40850,
    "api_key": "[REDACTED]"

You can also do it with the file editor but you need to remove .storage from ignore_pattern in the file-editor configuration.

It might be that you can skip this step completely and just remove the integration and let it be rediscovered, but I’m not sure so I edited the file instead. After this I had to restart HA to make it apply, and then all my sensors started working again.

Hopefully this is helpful, if I’m my instructions are unclear let me know.