Deconz Conbee 2 manual FW update?

hey guys…desperately need to update deconz conbee 2 to the latest FW version while waiting for the HA addon to be updated.How do I manually update on a supervised HA? Tried unplugging, updating the FW on a Win10 machine (goes OK), and then when I connect it back to the HA machine it keeps showing the old FW version. What’s up with that?!

alternatively, I tried from a deconz addon docker shell: /usr/bin/GCFFlasher_internal -d /dev/ttyACM0 -f /usr/share/deCONZ/firmware/deCONZ_ConBeeII_0xXXXXXXX.bin.GCF but I keep getting 781: permission error while locking the device…so this route was a no go either

Did you follow this guide and most importantly did you stop the deconz addon before trying to upgrade? You can’t upgrade while the container is running.

I did look at this giude but it seems it’s for another addon - marthoc, while I’m on the official one from the addon store. Do you know how exactly I should modify this line?

docker run -it --rm --device=/dev/ttyUSB0 --privileged --cap-add=ALL -v /lib/modules:/lib/modules --entrypoint "/" marthoc/hassio-addon-deconz-armhf

The other thing is that the update file is not there! I don’t have the latest file inside the docker container. This line from the logs shows a very old FW image from May 2020.

GW update firmware found: /usr/share/deCONZ/firmware/deCONZ_Rpi_0x262f0500.bin.GCF

Ah sorry didn’t know there were multiple addons.

The official instructions here didn’t work?

Nope…the actual instructions are missing. There’s just a link to the marthoc addon manual install sequence :frowning:

What you mean the actual instructions are missing? The second link I sent says to update through Phoscon.

That’ll be still considered an automatic upgrade (via Phoscon) where it currently says that I’m on the latest. The actual manual update instructions for the “official” add on seem to be missing, whereas they have the instructions for manual for marthoc’s deconz image…

I think I have it somewhat figured out. I have successfully updated the Conbee ii stick’s firmware to the latest (26650700), but my deconz software is behind (.79). My question now is how do I upgrade this alone?

I’m not sure, but I think you can’t update the deconz software with the add-on, you need to wait until the add-on updates the deconz software.

Seems this is the case :frowning:

I’m very interested in this. Could you elaborate on how you got the firmware file into the container and ran the script? That’d be much appreciated!

I didn’t. Plugged the Conbee stick into a WIN10 machine, intalled Deconz there, updated the stick, took it back to the HA machine.