deConz(ConBee 2) Phoscon can't add any devices

After trying to integrate my Xiaomi/Aqara sensors into HomeAssistant(HassIo) but failed due to the firmware update(Link to forum) I have moved on to trying deConz.

So fare I have been unsuccessful in adding any sensors using the Phoscon WebUI.

My setup:

What I have done so fare:

  • Rebooting the raspberry pi
  • Tried adding multiple aqara sensors from Phoscon WebUI (no luck)
    • Tried more than 3 scans with multiple resets of the sensors
  • Connecting the ConBee 2 into my win10 pc and using the DeConz software
    • It didn’t find it

What could the problem be? Am I doing something wrong?

Is the conbee actually identified properly? If that is the case you should see a proper firmware for it in phoscon -> view -> gateway

Well I think you mean Phoscon -> Settings -> Gateway, there is no View -> Gateway.

However this is what i see in the the Settings -> Gateway:

So then deCONZ doesn’t actually see the hardware. Conbee 2 is available under /dev/ttyACM0 or something like that

That actually makes sense why it can’t add any devices… I tried using /dev/tty/USB0, and thought it worked since it had the WebUI appear. Let me try /dev/ttyACM0 instead.

This yielded a different log from the addon: and it doesn’t seem correct.

Especially when it say:

19:39:27:641 COM: --dev: /dev/ttyAMA0 (RaspBee)

in the other log when using /dev/ttyUSB0 it said

18:30:23:642 COM: --dev: /dev/ttyUSB0 (ConBee)
1 Like

I guess the docs aren’t updated for conbee 2

Does that means I’m using the wrong port or what?

I think so

I finally found the solution!

The problem was as that I used the wrong serial port.
In my case the port was “/dev/ttyACM0”, and the way i figured it out was to use SSH to connect to it and ran:

hassio hardware info

This showed the serial ports in the bottom of the output. I then tried to unplug it, then ran the command again to figure out which serial port disappeared.


After 3 hours of frustration, i find your post and tryed the same. and it works… i almost cried :-):joy:

1 Like

You can also do this through the UI, FYI:



I know the feeling, I’m happy that this post could help you as well. Wouldn’t wish even my worst enemy to spend so many hours just to get the sensors up and running haha