Deconz error after upgrading to 0.78

Hello guys,

I am having an issue with my Deconz Component after upgrading to 0.78.
After reboot all of my Deconz devices sensors, lights are lost from the HA, however on the Deconz GUI everything is there any works fine. I found that in the Integrations menu (where Deconz is configured it shows as “Setup_error”.
Downgraded back to 0.77.3 and I am back to normal now, but waiting for solution possibly in the next update…


Enable debug for deconz component following directions in documentation. Do the upgrade and paste all info you get

Experiencing the same. Have not downgraded though.

Next step is providing logs to debug. Without debug data, there really is nothing I can do.

I’ll look at it tonight, and post what I find. Is it the log under dev-tools? Or is it a separate file?

1 Like

Yes. Check component documentation for how to enable debug logs

Not very good at this debugging stuff. Does it make sense, that it actually runs as intended, when in debug mode?

Log level shouldn’t change anything

Think I found something. It seems that a host reboot causes a setup error. After just restarting has through settings, it loads fine. Will try it out with debugger as well

Could it be something like deconz isn’t up and running at set up time?

Yes that is what I think it is causing it. Not able to check it right now, though.

I just enabled the debug and did an upgrade. Where can I find now the debug file?

In the main logs I see:

2018-09-23 19:43:19 ERROR (MainThread) [pydeconz.utils] Timeout getting deCONZ data from
2018-09-23 19:43:19 ERROR (MainThread) [pydeconz] Couldn’t load data from deCONZ

That is where you get the logs.

It would indeed seem that the component doesn’t cover this situation.

I will look into fixing this. I can’t promise when, within a release or two.

Interesting observation - it doesn’t work indeed if I try to activate the log level. It works as long as I don’t use logger with homeassistant.components.deconz. If I try to log deconz I get the same error as Csiza “couldn’t load data from deconz”.
As soon as I uncomment the logger deconz works as intended.
Just fyi.

For me it only work until version 0.77.3.
On 78.0, 78.1, 78.3 same issue. I am back on 77.3 now works fine everything and waiting for your fix Robben. Many thanks in advance.

Just adding myself to the list of users encountering this timeout issue when HA initially starts. Have been struggling the last day as I’ve migrated to a new SD card and thought there was something I’d screwed up, but appears it’s not my problem after all.

You might consider bringing up HA after deconz. In the HA service file (usually /etc/systemd/system/home-assistant.service) put deconz-gui.service in the [Unit] After= section.

I tried all different kind of order but the result is the same.

I still need logs