deCONZ not working after update

I recently updated hassio to 103.3 and the deCONZ addon to the latest version. Since then my deCONZ devices are not being recognized in HA. When I VNC to deCONZ, reading the devices works (2x Eurtotronic Spirit, 2 Xiaomi motions sensors, 1x Aqara Temp sensor and 1x Aqara door sensor). Also, the phoson GUI isn’t loading up when I go to IP.40850, instead it shows “Site couldn’t be reached, IP refused to connect”. But when I go to “open WebGUI” in the deCONZ addon page, it opens up. The devices are still shown under config --> integrations --> deCONZ, but no battery status is shown (probably meaning it isn’t receiving any infos from the addon)
I think the issue started when I upgraded the deCONZ addon. I updated hassio after it stopped working.
Here the log:

I obviously rebooted everything. I still have a snapshot from a few days which I might try, but I wanna get it fixed without reverting back.

Edit: Stupid-me didn’t think of checking the github:

Lots of changes with 4.1. First, to get to the web site, you now turn it on the “Show in Sidebar” switch in the deconz setup/config screen. Second, a lot of folks have lost their config and frankly, I’m seeing the easiest way to fix it is to start over and reconfigure each device.
I’m sure there are fixes in the works but… that was my track.

Thanks for the reply! I just re-added deCONZ in HA. That solved the issue.

after an update I lost all my deconz devices too. What do you mean to “re add” the deconz in HA? Please give the steps you did

Im also facing the same issue after updating to latest deconz version. After upgrade all my “nodes” from deconz are showing up as unavailable in hassio.
Have tried to uninstall and install deconz add on, but still no luck.
Has anyone figured out a solution to this?