deCONZ - Official thread

Anyone have any clue?

I am without light in the whole house

check the port, was my issue when i first got it

the info on the info pages is very good but you need to be exact for the thing to work otherwise it just looks like its working and then discons

Which port do I have to put?

It’s written not required for ingress, so there is none

The port that the USB device shows up as.
Typically this is /dev/ttyACM0 but you’re going to have to check on your own system to verify.

This i put and its correct, is the one I g et from system information

device: >

It does connect to the device, problem is it disconnects

When I put a wrong USB address I get different errors in log.

EDIT I changed USB port on the NUC, but niothing, nothing I do helps.

In device if I put

device: >-

I get this LOG, connects but it disconnect. If I go to VNC I see that it fhas COnbeeII byt can-t connect

king user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] executing... 
[21:48:30] INFO: GCFFlasher V3_13 (c) dresden elektronik ingenieurtechnik gmbh
Path             | Vendor | Product | Serial     | Type
/dev/ttyACM0     | 0x1CF1 | 0x0030  |            | ConBee II 
/dev/ttyACM1     | 0x1CF1 | 0x0030  |            | ConBee II 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] done.
[services.d] starting services
[19:48:30] INFO: Running the OSRAM LEdvance OTA updater...
[21:48:30] INFO: Websockify waiting for VNC to start
[services.d] done.
[19:48:31] INFO: Starting udevd...
[19:48:31] INFO: Running the deCONZ OTA updater...
[19:48:31] INFO: Running the IKEA OTA updater...
[21:48:31] INFO: Waiting for device...
[21:48:36] INFO: Starting VNC server (local/yes)...
[21:48:36] INFO: Starting websockify...
WebSocket server settings:
  - Listen on
  - Flash security policy server
  - Web server. Web root: /usr/share/novnc
  - No SSL/TLS support (no cert file)
  - proxying from to
[21:48:39] INFO: deCONZ waiting for VNC to start
[21:48:39] INFO: Starting the deCONZ gateway...
libpng warning: iCCP: known incorrect sRGB profile
21:48:40:837 HTTP Server listen on address, port: 40850, root: /usr/share/deCONZ/webapp/
21:48:40:859 CTRL. 3.27.221:48:40:915 COM: /dev/ttyACM1 / serialno: DE2195369
21:48:40:917 COM: --dev: /dev/ttyACM1 (ConBee II)
21:48:40:917 ZCLDB init file /data/.local/share/dresden-elektronik/deCONZ/zcldb.txt
21:48:40:991 parent process s6-supervise
21:48:40:991 gw run mode: docker/hassio
21:48:40:991 GW sd-card image version file does not exist: /data/.local/share/dresden-elektronik/deCONZ/gw-version
21:48:40:991 DB sqlite version 3.27.2
21:48:40:992 DB PRAGMA page_count: 50
21:48:40:992 DB PRAGMA page_size: 4096
21:48:40:992 DB PRAGMA freelist_count: 3
21:48:40:992 DB file size 204800 bytes, free pages 3
21:48:40:992 DB PRAGMA user_version: 6
21:48:40:992 DB cleanup
21:48:40:993 DB create temporary views
21:48:41:008 don't close database yet, keep open for 900 seconds
21:48:41:009 started websocket server at port 8081
21:48:41:011 found node plugin: - REST API Plugin
21:48:41:013 found node plugin: - Signal Monitor Plugin
[19:48:41] INFO: Starting Nginx...
2020/08/31 19:48:41 [notice] 337#337: using the "epoll" event method
2020/08/31 19:48:41 [notice] 337#337: nginx/1.14.2
2020/08/31 19:48:41 [notice] 337#337: OS: Linux 5.4.56
2020/08/31 19:48:41 [notice] 337#337: getrlimit(RLIMIT_NOFILE): 1048576:1048576
2020/08/31 19:48:41 [notice] 337#337: start worker processes
2020/08/31 19:48:41 [notice] 337#337: start worker process 1588
21:48:43:996 found node plugin: - STD OTAU Plugin
21:48:44:037 COM: /dev/ttyACM1 / serialno: DE2195369
21:48:44:037 COM: --dev: /dev/ttyACM1 (ConBee II) - - [31/Aug/2020:19:48:44 +0000] "GET /api/config?_=1598903322317 HTTP/1.1" 200 262 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36" - - [31/Aug/2020:19:48:44 +0000] "GET /api/hassio_ingress/Tns5H4FVOpBfhcciBXbvc0jbL4LjEb_Pw6_9LBtLEcA/api/config?_=1598903325329 HTTP/1.1" 403 140 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36"
21:48:46:144 Announced to internet

now I put back my COnbee 1 (It lost all nodes so I thought it was broken, that’s why I bought a Conbee II)), this gets recognized immediately, but all connectiuon between nodes are lost

WTF, I am at a point of throwing everthing in the garbage


I repaired evwerythging, and again all connections between nodes are lost.

This is pure crap

I use conbee 2 and Pi 3b+. Manual update firmware in Hassio seems to be hard to me. Is it ok to update firmware by Pc with windows 10 and Phoscon app then use it again with Pi 3?

Seems this night add-on stopped again, lots of users were reporting it again, seems when add-on stops, it also happens at the same time for other users too

Maybe it is a useful information for one or the other.
I read all this issues and avoided to upgrade so far.
I’m running hassio on RASPB3+ and deCOnz 5.3.4.
It is rock solid and stable.
This is the Firmware:
Maybe, one can get back to this version and reach stability again.

1 Like

I think the cause is the build in VNC server, that was added in last release, gonna disable that , (web vnc)

lots of users reporting now, that deconz addon stopped this night, all around 23.45

Very strange that everyone posted about the issue of the addon crashing about 10 days ago, the issue went quiet while nobody (presumably) had the issue, then yesterday all of a sudden a whole wave of people had the exact same problem again.

I’m not sure what it means, but it’s suspicious.

my guess its the built ingress VNC server that crashes or something like that :slight_smile:
maybe its a trial version :slight_smile:
the releases before without VNC ingress werent affected

ohh so my problems are common?

I solved by putting the USB stick on another machine and now it seems working (did not put all the nodes back pairing though, because its a lot of work, door sensor, switches and so on, and I was tired of pairing, and then have to repeat all again).
Total devices are around 80, perhaps thats the problem?

I have some xiaomi motion and water leak sensors, they are reporting also temperature in phoscon, but I don’t see a sensor for that in HA… Is that normal?

Yes, that’s normal. It’s because they are quite shit and never show the correct temp. You can still find it as attribute of the binary sensor.
This also applies to door & vibration sensors.

ow indeed, they are an attribute , didnt notice
but indeed, temp is wrong, showing 30° right now, i think its only like 20° :slight_smile:

Just what I did.

I had it on a stand-alone Pi and it became unstable as I have about 45 devices. I run HA in an Ubuntu LXC on Proxmox, so I added an Ubuntu KVM for DeCONZ and installed it from apt. It has been rock solid for about 4 months now.

I have 133 devices and use deconz as an addon in hassos and a rbpi4. No problems with it.