deCONZ - Official thread

Zigbee gateway aiming to support most manufacturers. Works with Conbee and Raspbee hardware.

I’ve been thinking about keeping a common thread for deCONZ since there are so many different support errands around it and a lot of spread out undocumented knowledge in all you users.

I’d also like to get users of deCONZ regardless of systems to join in to a common discord. [email protected]

2 Likes

Cool, I’m going to be first to post! :slight_smile:

I have an issue after latest upgrade (now on 0.88.1) where the Deconz integration configuration becomes “duplicated” after reboot.

Config entry failed since one deCONZ instance already exists

This is what I get from the HA log, the Deconz log looks perfectly fine. I’ve been trying to uncomment discovery: since I was guessing that it was might be causing this, but it doesn’t make a difference.

What I need to do is to remove the integration, reboot and add it again and then everything is fine until next reboot. Anyone had the same issue? It’s clear that it’s not a common 0.88 issue since then more people would have been affected.

I experienced the same thing (with 0.88.0) - also fixed it by deleting the integration and adding it again. Been working perfectly since.

Have you restarted HA after that? The challenge is that my issue comes back at each restart.

Yes, plenty of times, as I’ve been tinkering a lot - only saw it that one time.

Bummer :frowning:

I had the same thing this morning and none of the devices worked, the deCONZ integration was empty of device icons in the ‘Integrations - Configured’ page but visible if I clicked on the deCONZ integration. I deleted, restarted and added, worked fine but on restart, had the same issue.

As this only happened overnight, I thought, I had installed custom-updater yesterday so I uninstalled that and restarted, added deCONZ again and all works fine on reboot.

Can’t be 100% sure it’s that but with custom-updater running/installed HA took a long time to restart and deCONZ is working fine now

1 Like

I’m not sure what you mean with a custom updater?

Guess you don’t have this installed ?

Now when I read about it, I remember. I did fiddle around a little with that when I switched to Lovelace. But I didn’t like it, so commented it away in configuration.yaml and forgot about it. Apparently I left the file in the custom components folder, now I deleted it and boom! No Deconz issues anymore. Thanks!!

Strange, no idea why its linked

Thanks a lot.
I can confirm. Removed custom_updater component.
deCONZ is working fine now.

Uh?
And why should be a connection with the two. Of course I can disable custom updater, although I hope for a fix, since I really like the custom updater concept.

Removing custom_updater from custom_components and configuration.yaml did not fix the problem for me.

@Holdestmade could you elaborate on how you removed custom_updater?
Do you still have /.storage/custom_updater.cards?
I have completely removed all custom_updater related items, including my custom cards and i still loose my deCONZ integration each restart.

I use both deconz and custom updates. I’ve not seen any issues since updating to 0.88. So whilst Custom updates may be somehow related to your issue, it’s certainly not a problem for everyone.

Tbh I’m not sure how it could have an impact, did you change anything else when you disabled it? Have you re-enabled it and seen the duplicates return?

I just commented out the items from configuration.yaml, moved the file in custom components folder and commented out uilovelace.yaml. When I readded, it caused the problem again. Removed it and it works fine. Not sure why this is an can’t see why it would do it but it does for me.

In my custom_components i have:

/custom_updater.py
/enable_debug.py
/sun.py
/synology_home_mode.py
/variable.py

When i remove them all, deCONZ integration still fails on reboot. So as far as my installation goes, custom_components doesn’t seem to have anything to do with it…

I hade the same problem. Phoscon works but all entities disappeared from home assistant. Commented custom_updater in config.yaml and now it all works great again.

I don’t uinderstand how that can be the issue.

Anyway I tried too and … deCONZ still diasppears after restart

I did a couple of restarts with custom updater commented. Worked. Added custom_updater again and deconz entities disappeared. Removed custom_updater and deconz entities came back.

All you did was comment out custom_updater: in configuration.yaml?