Deebot 601 not working, is it compatible?

Recently got an Ecovacs Deebot 601, and I figure I will try to make it work with HA (Running HassOS 2.6, HA 0.93.1). Configure the ecovacs components, seem like it is “properly configured” but I keep on getting an error:

WARNING (SyncWorker_9) [sucks] Ping did not reach VacBot. Will retry.

When I look at the logs in more details, I see that my HA server reaches an ecovacs server, I can see that it validates the account and gets the correct Ecovacs ID and respective email address (same as what I see in the Ecovacs Home App). I can see that there is an access token generated, then a UID (assuming unique ID) ; so seems like the communication is the correct one, but it gets to a point where this is what I get:

DEBUG (event_thread_0) [sucks] *** sending ping ***

DEBUG (send_thread) [sleekxmppfs.xmlstream.xmlstream] SEND: <iq id="some_ID" type="get" to="" from="[email protected]/random_code"><ping xmlns="urn:xmpp:ping" /></iq>

DEBUG (read_thread) [sleekxmppfs.xmlstream.xmlstream] RECV: <iq type="error" to="[email protected]/random_code" from="" id="some_ID"><error type="wait" code="404"><recipient-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" /></error></iq>

WARNING (event_thread_0) [sucks] Ping did not reach VacBot. Will retry.

DEBUG (event_thread_0) [sucks] *** Error type: wait

DEBUG (event_thread_0) [sucks] *** Error condition: recipient-unavailable

I am in the US and I have the country set to US and continent set to NA. Is there anything I am missing, or is there a problem with compatibility of the Deebot 601 and the Ecovacs component in Home Assistant? Any help will be greatly appreciated.

The docs say na not NA. I am not sure if that makes a difference. Also note that the correct continent might be ww for worldwide.

This hasnt worked for me either even after overload fixed it, I talked to him and he was going to look into it.

@nickrout, I tried NA and na, as well as WW and ww; doesn;t seemed to make any difference; maybe there is something with the 601 that makes it not compatible. I know that the rest of units listed as compatible use a difference mobile app (ecovacs as opposed to ecovacs home). I will keep poking around to see if I find anything else to make it work.

@monsieurlatte, thanks for the heads up. Hopefully there is a way to make it work, I will keep on looking around.

I found Interacting with my Ecovacs Deebot robotic vacuum with Python & Sucks where the author explains they have the same problem (i.e. <error type="wait" code="404"><recipient-unavailable ...>) and that they’ve changed to a fork of sucks.

With this fork, I have managed to control my deebot from my CLI. The README on the fork should be improved, here are the steps that I had to run and that are not explained:

pip3 install pipenv
pipenv shell

and in the new pipenv shell install the packages

pip3 install paho-mqtt
pip3 install sleekxmppfs
pip3 install click
pip3 install requests
pip3 install pycryptodome
pip3 install pycountry-convert
pip3 install stringcase

You can close the pipenv shell with ^ + D (Ctrl+D) and then use sucks as described in the README file.

./ login
./ charge
./ clean 15 edge 5

And so on.

I’ll check how to integrate this with my install when I’ll have some free time.

Following the changes proposed here FIXED: Ecovacs Deebot 2019 & OZMO Series - Working Library allows me to use my Ecovacs Deebot 605.

(Commenting for anyone finding this entry from Google)