Defang Wyze v2 RTSP No Audio

I just installed the defang hack on my wyze v2 and it seems to be working great so far, the only issue so far is that I can’t get audio to work in Home Assistant. Audio stream works via VLC, but when I put it in HA the volume icon is crossed out. This is my config

platform: generic
stream_source: rtsp://admin:[email protected]:8554/unicast
still_image_url: https://x.x.x.x/cgi-bin/currentpic.cgi
username: !secret defang_username
password: !secret defang_password
authentication: basic
verify_ssl: false
name: Garage Defang


I’ve also tried ffmpeg in HA, as well as changing the audio from mp3 to PCMU. Nothing seems to work. Any ideas on how to get audio in the RTSP stream into HA?

I’m having exactly the same problem. I’m using the most recent RTSP firmware on the cameras, and the setup is basically stock in every respect except turning on RTSP. They run quite well otherwise, but I can’t get audio. I get audio when viewing the stream via Desktop VLC on my computer. I can also get audio from other test streams. I’ve tried to do an extensive web-search on this question, but I’ve come up empty.

Is anyone else having the same experience or whether they are successfully getting audio?