Delete automations

Hi for some reason can’t delete automations or entities any longer, the delete option is greyed out.
Went into developer-tools/states click on the “circled i” on the left of the automation you want to delete. There will be an option to delete in the dialog box that is brought up.

Used to work but seems to have started to do this lately

Try disabling them first. I had the same thing with some other random entities. I couldn’t delete them until I disabled them and restarted…then I could delete them.

Tried that but for some reason when I disable the Automation it dissapears and can’t find anywhere

How did you create the automations? thru the UI or in yaml?

A bit of both, all is greyed out, ones done through yaml and ones through automation. Even the entities I can’t delete. Wierd

Hi still no answer on this. Noticed many people have same problem and it falls dead after a while.
Why can’t I delete automations or entities? delete button shown but can’t click it.
Tried from developer tools using the circled I
tried from configuration entities and I get
You can only remove 0 of the selected 1 entities. Entities can only be removed when the integration is no longer providing the entities. Sometimes you have to restart Home Assistant before you can remove the entities of a removed integration. Are you sure you want to remove the removable entities?

Not sure what to do next why is it so complicated to remove what we don’t need.
If we play around making different automations and decide to remove them we can which makes a long list of items to go through when we need to access automations and entities we do use.
It used to work before and suddenly stopped.

I can go into file editor registration and automations and remove manually but this is a looooong process and one wrong move and everything will crash.

If it can help anyone else I finally found how to delete.
Like mentioned if you go to the I in developer tools delete is greyed out.

you need to go into the automation edit and 3 dots at top corner you will see delete automation.
voila gone. I am not sure it appeared with latesr 2020.12.0 update could swear it wasn’t there before.

Went to file editor automations and core.entity_registry and they are deleted from there also


Thankyou, been trying to figure out how to delete automations for a while now :slight_smile:

1 Like

Thank you for this solution. I am sure the delete button use to be available on the “information” page for the automation, but now it is just greyed out.
At least the edit - menu - delete option works :slight_smile:
Now I just have to work out how to delete two duplicate DeCONZ groups that are present in Home Assistant but not DeCONZ, but that is a totally different thread :slight_smile:

1 Like

Thank you for posting the solution. It helped me fix my problem :slight_smile:

1 Like

OMG !!!

Why ???