Delete entity when the integration is removed?

I used to have MyQ but when that imploded I got a ratgdo. Working on setting it up now, but I cannot delete the old cover.garage_door entity. I want to delete it so that the ratdgo entity can be renamed with that so any automations or alerts won’t need to get updated. Home Assistant has been restarted many times since MyQ was removed, but I still have this orphaned entity that I can’t remove. Any ideas on how to remove it when the integration itself is gone?

Here are the screenshots of what I’m seeing:

Have rebooted HA once and try again.

Yeah, still the same result, even with rebooting (rather than just restarting) everything.

Also tired rebooting in Safe Mode with the same result.

Can you enable it before deleting?

Nope, enable is all grayed out.

Can you open device settings in 3rd picture?

Yeah, but I can’t enable it that way either as the toggle switch is grayed out and won’t change.

Take a look at this:
Use at your own risk, but it has been a lifesaver for me.
Sample code in the Services tool:

service: ha_registry.remove_entity
    - sensor.YOUR_SENSOR_HERE

Can you open the settings in the second picture?

at the bottom left there should be a delete button.

That’s the next screenshot - unfortunately the delete button is gray out and inactive.

1 Like

This seems like it’s going to be what I have to do. I’ve found other thread where people reference it. I do backups every night so if I screw something up and worst comes to worst I just nuke the entire thing and restore from backup.

Edit: Did this and it was super easy and it worked immediately!