Deleting unavailable entities manually

For some reason I have a lot of duplicate entities. One of the 2 is unavailable and that is the one I need to delete because this one is not correct. See screenshot:

I’m using, latest versions.

Thanks for you help.

Put a check in the checkbox, then

That’s not possible !!!
I cannot enable the checkbox for the unavailable devices

What kind of switch is it ? It is not a mqtt one, this would show MQTT. So it must be some other one.

How do I know? It is created during the time (last week) I create all MQTT devices.

You don’t see anything with that name in configuration.yaml or switch.yaml ?

Every MQTT light also have a read only switch identity with nearly the same name

Is there not a simple way to just delete readonly entities?

Try the 0.108 update. I saw there is a delete button on devices now.


I have to delete entities, not devices.
But after upgrading to 0.108 I don’t see the delete button on neither entities or devices.

I’m not seeing a way to remove devices either. I have extraneous google home devices.

I’m also seeing this issue - can’t delete an old entity in UI, as above. I’ve tried searching for the device ID in config directory and child directories and nothing shows up. I’ve also looked in .storage/core.* files and its not there either.

The only thing I see is Binary file home-assistant_v2.db matches for a grep on the ID. I don’t want to blow my DB away as I have some run-time totals I’m tracking (which I should move into external DB, I know).

EDIT: I found a reference to the entity in my config file - it was a light group with only a “friendly” name specified, which is why my initial greps didn’t work. Viewing a copy of my SQLite DB file was the trick.

Had the same issue while my entities were generated after playing with the Milight hub and MQTT. I tried a restart of HA, but without result. I than executed ‘reload MQTT entities’ and all are gone. Hopefully the ones that I need will appear again. At least all bogy entities are gone.
The ‘reload MQTT entities’ can be found under: Configuration, Tab ‘Server controls’ and scroll down.

I have these “dead” entities… They are from my old IKEA hub. How can I remove these?


Same here. Light already removed in the IKEA app, integration “reloaded” in the integrations panel… Can’t remove nor the device, nor the entity.

Did anyone find a solution for this issue?
I can’t remove the entities of “a better presence”

Similar issue here:
I have 2 EVE Energy and 1 EVE Door/Window which I had integrated thru Matter. Initially this worked fine but somewhere along the line they became UNAVAILABLE. I have reloaded the Matter Integration, Restarted HA, rebooted the whole system (HA Yellow), nothing helped.
HA does not allow to delete Entities which are unavailable. I have also deleted the Matter Integration (+ restart; + reboot) in the hope the rogue entities would disappear.
Unfortunately this did not help either, the devices/entities are still listed and unavailable.

I would appreciate guidance as t how to get rid of these.

Many thanks in advance!

In HACS you will find Spook

Delete all orphaned entities

Mass clean up your Home Assistant by deleting all orphaned entities in one go.

Orphaned entities are entities that are no longer claimed by an integration. This can happen when an integration is removed or when an integration is no longer working. Home Assistant considers an entity only orphaned if it has been unclaimed since the last restart of Home Assistant.

Thanks Francis, I went thru the whole installation process (HACS, Spook) and then ran the service. It gives me the green tick in the box, but the orphaned entities are still there. I tried another spook service (delete area) and that worked fine.

This is what YAML mode shows:

If you have a tip as to what I need to do I’d be very thankful !

I had tried many things including deleting the Matter integration and add-on; run the orphan integration and reboot the whole system. Nothing worked, The unavailable entities did not disappear.

BUT: I installed HA 2023.8.3 this morning and they are gone.!!!

Don‘t know what did the trick but I am happy.