Denon AVR no longer working

I’ve just updated HA Core and OS, and now my Denon AVR integration is no longer working. Any idea if there’s anything I can do?

Logger: homeassistant.config_entries
Source: components/denonavr/
First occurred: 09:25:39 (1 occurrences)
Last logged: 09:25:39
Error setting up entry Denon AVR-X2400H for denonavr

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 236, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/usr/src/homeassistant/homeassistant/components/denonavr/", line 71, in async_setup_entry
    if not await connect_denonavr.async_connect_receiver():
  File "/usr/src/homeassistant/homeassistant/components/denonavr/", line 33, in async_connect_receiver
    if not await self._hass.async_add_executor_job(self.init_receiver_class):
  File "/usr/local/lib/python3.8/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/denonavr/", line 66, in init_receiver_class
    self._receiver = denonavr.DenonAVR(
  File "/usr/local/lib/python3.8/site-packages/denonavr/", line 344, in __init__
  File "/usr/local/lib/python3.8/site-packages/denonavr/", line 527, in update
    return bool(self._update_avr_2016())
  File "/usr/local/lib/python3.8/site-packages/denonavr/", line 644, in _update_avr_2016
  File "/usr/local/lib/python3.8/site-packages/denonavr/", line 109, in update
    self.dynamiceq = bool(int(param.text))
TypeError: int() argument must be a string, a bytes-like object or a number, not 'NoneType'

1 Like

Same here, with a Marantz NR-1605 (which uses the Denon integration). My stack trace starts a little differently, but is the same from line 33, in async_connect_receiver down.

Luckily we’re not alone:

Looks like it is already known about -

I have a x4000 , better to wait to upgrade then

Yep not working for me either, damn it, the one time i didn’t wait for the initial patch and upgraded.

I think you can always revert to previous version, by loading it as a custom component

Lol same. I recently got a new amp for my subwoofer and a switch in HA that I sync with my receiver power status so it goes on/off automatically. So I hope they will publish it soon.

is this still an issue? i dont see yet an 2012.12.01 :slight_smile:

still 118.5 here

Yep for sure. Wondering when new update will arrive.

I don’t see it yet for next update…

Exactly the same error of here.

TypeError: int() argument must be a string, a bytes-like object or a number, not ‘NoneType’

should be fixed in latest release.

Yes it is working now
Offtopic: anybody willing to share how they configured their Denon AVR in lovelace (I’m assuming using the custom mini player).
The fact that the Denon AVR needs to be controlled by the Denon integration or the HEOS integration depending on what you’re trying to achieve makes it a bit challenging :slight_smile:

Since Upgrade to core 6.4 my Denon x4400h cant be found by HA Integration anymore, IP is not reachable. Before it worked perfectly. Ive restarted the AVR, HEOS works fine… anyone else?

Why is it so hard to use the search function and sort to see the latest posts?

I have 3 Denon AVRs (X1100W and 2x E-300) no longer communicating after upgrading to 6.4 as well.

Known problem…

do a partial restore of just 6.3 from your backup…

I’m in the same boat - my AVR-X8500H can’t be contacted from HA either although strangely, the HA device can ping the AVR.

core-2021.6.5 update fixed the issues on my denons

I upgraded and readded via ip. all working again

thank you guys who ever fixed it.

Kind regards from germany !

1 Like