Denonavr not visible in integrations

hi - i made the required changes in my configuration.yaml to add denonavr

however, i am unable to complete the integration as denonavr is not one of the 40-50 items on the dropdown list…

please help - thanks.

At the bottom of the dropdown list is a link to more integrations. Then pick “Media Player” in the left column. Viola. This works great with the AVR series of receivers, all the way back to the AVR-X1000

thanks a ton @Dansker

however, i do not see a link to more integrations further down my list/

is it possible that this is happening because python is 3.6.9 on my linux machine? I have tried to install 3.7 (incuding venv 3.7, and pip 3.7), but installation fails to complete…

thanks again!

Hmm, must not be talking about the same “dropdown list” I do not have the knowledge to answer your python question.

Not quite clear if you are looking for something to download? -there is nothing to download, it should just work.

Post the lines from your config, and what is the model number of your receiver? Did you look under “Developer Tools:States” for your receiver (media_player.your_receivers_name)?

FYI: The next version of HA, 112, will have a new procedure to install the Denon integration…

1 Like

thanks. will wait for the next version.

my receiver is AVR-3312 (and is included in the list of verified AVRs).

The new configuration method is just a “form” which takes to same information. If it does not work for you now, I am not sure the new method fixes your problem. Post your configuration lines, if you wish.

How are you running Home Assistant? I assume in a venv from your post, correct? Which version of HA are you running?
Please post your relevant configuration.yaml code. And which dropdown list are you talking about?

Thank you both. Here is the configuration.yaml file

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

discovery:
  ignore:
    - denonavr

# Example configuration.yaml entry
media_player:
  - platform: denonavr
    host: 192.168.0.13
    name: ourDENON3312
    show_all_sources: true
    timeout: 3
    zones:
      - zone: Zone2 / Zone3
        name: NewZone

When I try to see if HA can detect my AVR automatically, and sees that it does not, I tried to add integrations by clicking the + sign at the bottom right of the screen, and there are several options in there, none of which are denonavr…

The other thing that is troubling me is that i am running this on a deprecated python 3.6 environment. I am struggling to create a fresh env using python3.7.

Running this on an Ubuntu 18.04 machine…

Thanks for your help!

This is because denonavr is not available to be configured through the UI, it will be added in today’s release. Only integrations configurable through the UI will appear in this dropdown.

What version of Home Assistant are you running?

Do you get any errors in the logs with this config? Developer Tools -> Logs

Try changing your code to this:

media_player:
  - platform: denonavr
    host: 192.168.0.13
    name: ourDENON3312
    show_all_sources: true
    timeout: 3
    zones:
      - zone: Zone2
        name: Zone 2
      - zone: Zone3
        name: Zone 3

I assume you need to add each zone individually.

1 Like

thanks so much for your patient and helpful pointers! looking forward to the release today!

hi.
i removed denonavr from configuration yaml, update do 0.112. restart HA, try to add X2100W from integration but denonavr on ip 192.168.1.142 not found.
i have it working as mediaplayer since, i think, 0.9x

i can ping 192.168.1.142 and if i try from command line wget http://192.168.1.142/goform/Deviceinfo.xml i can DL info from Denon.

from integration i can add denonavr with ip “192.168.1. 142” yes with space!
it create entity but … nothing more work

There are some posts along the line of your problem. Skipped 112.0, but installed 112.1, re-added three Denons, all worked first time.

Did have to rename the entities back to what they were before the update.

Do get some errors in the log:

Input function SOURCE is not known

However, all seem to work fine.