Detect power on/off tools in zigbee

Hello everyone,

I’m looking for a sensor that can dectect that a tools in my workshop is running. I need something in real time, as I want create an automation that open the slidegate of the dust collection system and start the shopvac. SO I need to detect the start of the tool within 1-2 secconds after.
In addition, I would like to do in Zigbee ZHA if possible, as I use this systeme right now

The smartplug with poser consumption seems to not refresh enough fastre for this task, As I test 3 different of them.

Thanks for your help

Maybe a motion detector?

You can try create dropdown helper that will change the status of device you want to monitor.
Then you create automations that will set status of device calling service input select: select status.
I don’t know will it change status in 1-2 sec. Depends, maybe it will need a few sec more.

You need to look into changing the update frequency in HA.
I think it is standard 30 secs, but how low you can get it and at what costs I do not know.

I was thinking to this kind of sensor too, butIt won’t suit all my needs. It could do it for big stationnary machine, but not for electric hand tool like an disk sander for example. Plus It migh trigger on the system when I put something on the machine even if I don’t use it.

Where can you chnage this parameter, I dont see this option

I’m not sure If I correctly understand what you mean, but that implies a manual action to indicate to HA that I use a specific tool no ?
I would like to do that without manual action on the system, just by start the electric tool

No, it doesnt. In dropdown helper you will create status of a device ie running, ready, finished… After that you will create automation that will set status of a device. So when something changes on the device ie. you plug it in, it consumes a bit of electricity you know that is ready to run. When you run it it will show you status running, when you switch it off it will show you status off.
There is no manual action, status is updated based on running conditions by automation.
You can find a detail explanation here.

Maybe with the service call: “Home Assistant Core Integration: Update entity”

This is only working if the Zigbee device is reporting in faster than the update frequency.
The service call will then refresh the HA data with the update data reported in.

If this does not work, then I think ESPHome is the best way to go.
ESPHome is not Zigbee, but you can better control the firmware on the sensor device.

You are really making things more complex than it should be. He just need a sensor that will detect that some tool is running. The best and the simplest way to do it is by creating dropdown helper and automations that will change the status of machine. I use this on a few dumb machines and this does work flawlessly.

A dropdown helper is a not a autonomous sensor.
It need to be set by a manual action, which means there is not the wanted detection, or it can be set by automations, which needs to be based on sensors and then we are back at the root cause.

I’ve read the post and I think I get it. Unfortunately my problem is to find a sensor that can give me the power consumption enough faster and consistently. So far the smart plugged with power mesure I tried did not update the data enough faster (between 3-4s but up to 10-15s). It is too slow for my use. So unless I didn’t understand the drop down, I don’t think it will solve my problem

Hello, I think I will try ESPHome for that
I must add that I use HomeAssistant in a docker installation with an old Notebook (Samsung NC10 on Xubuntu 18.04)
I tried to install a docker container of ESPHome (I found one on https://hub.docker.com/ esphome/esphome-base-i386 because the docker pull ghcr.io/esphome/esphome command did not work for me (i says : no matching manifest for linux/386 in the manifest list entries)

But when I trie the commande to run the container
docker run --rm -v "${PWD}":/config -it esphome/esphome-base-i386 wizard esphome.yaml
I’ve got this error:
docker: Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: "wizard": executable file not found in $PATH: unknown.

Anybody can help ?

I’m using docker installation. This is my docker-compose.yml part for esphome

  esphome:
    container_name: esphome
    image: esphome/esphome
    volumes:
      - /opt/esphome/config:/config
      - /etc/localtime:/etc/localtime:ro
#    ports:
#      - 6052:6052
    restart: always
    privileged: true
    network_mode: host