/dev/ttyACM0 does not exists anymore


I have a NUC with Z-Stick Gen 5 plugged.
It was working fine but then I updated linux (apt update upgrade…) and HA (with GUI) and now the zwave is not working.

I have a linux + virtualbox with Home assistant os.
I started to “debug” on linux :

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 003: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[  749.883555] usb 1-1: USB disconnect, device number 5
[  756.205873] usb 1-2: new full-speed USB device number 6 using xhci_hcd
[  756.355551] usb 1-2: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
[  756.355554] usb 1-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[  756.357011] cdc_acm 1-2:1.0: ttyACM0: USB ACM device
[  756.737999] usb 1-2: reset full-speed USB device number 6 using xhci_hcd
[  757.170558] usb 1-2: reset full-speed USB device number 6 using xhci_hcd

So for me the USB is well plug and linux detect it but it is not available in /dev/ttyACM0 as before and as describe in dmesg

ls /dev/tty*
/dev/tty    /dev/tty14  /dev/tty20  /dev/tty27  /dev/tty33  /dev/tty4   /dev/tty46  /dev/tty52  /dev/tty59  /dev/tty8    /dev/ttyS13  /dev/ttyS2   /dev/ttyS26  /dev/ttyS4
/dev/tty0   /dev/tty15  /dev/tty21  /dev/tty28  /dev/tty34  /dev/tty40  /dev/tty47  /dev/tty53  /dev/tty6   /dev/tty9    /dev/ttyS14  /dev/ttyS20  /dev/ttyS27  /dev/ttyS5
/dev/tty1   /dev/tty16  /dev/tty22  /dev/tty29  /dev/tty35  /dev/tty41  /dev/tty48  /dev/tty54  /dev/tty60  /dev/ttyS0   /dev/ttyS15  /dev/ttyS21  /dev/ttyS28  /dev/ttyS6
/dev/tty10  /dev/tty17  /dev/tty23  /dev/tty3   /dev/tty36  /dev/tty42  /dev/tty49  /dev/tty55  /dev/tty61  /dev/ttyS1   /dev/ttyS16  /dev/ttyS22  /dev/ttyS29  /dev/ttyS7
/dev/tty11  /dev/tty18  /dev/tty24  /dev/tty30  /dev/tty37  /dev/tty43  /dev/tty5   /dev/tty56  /dev/tty62  /dev/ttyS10  /dev/ttyS17  /dev/ttyS23  /dev/ttyS3   /dev/ttyS8
/dev/tty12  /dev/tty19  /dev/tty25  /dev/tty31  /dev/tty38  /dev/tty44  /dev/tty50  /dev/tty57  /dev/tty63  /dev/ttyS11  /dev/ttyS18  /dev/ttyS24  /dev/ttyS30  /dev/ttyS9
/dev/tty13  /dev/tty2   /dev/tty26  /dev/tty32  /dev/tty39  /dev/tty45  /dev/tty51  /dev/tty58  /dev/tty7   /dev/ttyS12  /dev/ttyS19  /dev/ttyS25  /dev/ttyS31  /dev/ttyprintk

If I unplug the stick, plug it again I do not see any differences in /dev/tty* without and with the stick.

Any ideas ?

Did you tried to use the /dev/serial/by-id/ device instead (usb*) ?
It was working for my previous Aeotec Z-Stick Gen 5 USB device
Best regards


Hello JF,
I do not have this in /dev

autofs           drm_dp_aux0  i2c-2         loop0   mqueue     port      snd     tty13  tty24  tty35  tty46  tty57  ttyS1   ttyS20  ttyS31     userio      vcsa   vcsu5
block            drm_dp_aux1  i2c-3         loop1   net        ppp       stderr  tty14  tty25  tty36  tty47  tty58  ttyS10  ttyS21  ttyS4      vboxdrv     vcsa1  vcsu6
btrfs-control    ecryptfs     i2c-4         loop2   null       psaux     stdin   tty15  tty26  tty37  tty48  tty59  ttyS11  ttyS22  ttyS5      vboxdrvu    vcsa2  vfio
bus              fd           i2c-5         loop3   nvme0      ptmx      stdout  tty16  tty27  tty38  tty49  tty6   ttyS12  ttyS23  ttyS6      vboxnetctl  vcsa3  vga_arbiter
char             full         i2c-6         loop4   nvme0n1    ptp0      tpm0    tty17  tty28  tty39  tty5   tty60  ttyS13  ttyS24  ttyS7      vboxusb     vcsa4  vhci
console          fuse         initctl       loop5   nvme0n1p1  pts       tpmrm0  tty18  tty29  tty4   tty50  tty61  ttyS14  ttyS25  ttyS8      vcs         vcsa5  vhost-net
core             gpiochip0    input         loop6   nvme0n1p2  random    tty     tty19  tty3   tty40  tty51  tty62  ttyS15  ttyS26  ttyS9      vcs1        vcsa6  vhost-vsock
cpu              hpet         kmsg          loop7   nvme0n1p3  rfkill    tty0    tty2   tty30  tty41  tty52  tty63  ttyS16  ttyS27  ttyprintk  vcs2        vcsu   zero
cpu_dma_latency  hugepages    kvm           mapper  nvme0n1p4  rtc       tty1    tty20  tty31  tty42  tty53  tty7   ttyS17  ttyS28  udmabuf    vcs3        vcsu1  zfs
cuse             hwrng        lightnvm      mcelog  nvme0n1p5  rtc0      tty10   tty21  tty32  tty43  tty54  tty8   ttyS18  ttyS29  uhid       vcs4        vcsu2
disk             i2c-0        log           mei0    nvme0n1p6  shm       tty11   tty22  tty33  tty44  tty55  tty9   ttyS19  ttyS3   uinput     vcs5        vcsu3
dri              i2c-1        loop-control  mem     nvram      snapshot  tty12   tty23  tty34  tty45  tty56  ttyS0  ttyS2   ttyS30  urandom    vcs6        vcsu4

No sure, but maybe you already link the stick to virtualbox VM and virtualbox has removed the local devices to avoid any conflict. Did you see them on HASS OS ?

Yes you’re right I can see them in hass os even /dev/ttyACM0
The integration does not have the config error but it is still not working, when I act on a light for example I get : “… Z-Wave error 8: The driver is not ready or has been destroyed”

Finally I found the problem, the device was not set in the config …/hassio/addon/core_zwave_js/config
I do not understand how this is possible. I had to setup /dev/Serial/by-id/usb-..... instead of /dev/ttyACM0 that was not available.

Thank you @jfweber

You are welcome :slight_smile: