Develco External Meter Interface (ZHEMI) suddenly offline

I have problems making ZHA stable, and during my attempts I have tried the migrate feature to reinitialize the coordinator. That has helped immensely, causing all my mains powered devices to be only always (just a week of testing so far), but the one battery device I have went offline 3 days ago.

I had a look at it and it did signal that it has no connection to the coordinator. There is a lake powered ZigBee device just a meter away but the device signal is good enough that out can be reached 9 meters away from another coordinator.

I tried triggering the ZigBee device (from the device) but that did nothing. Then I tried to open the coordinator for a new join and the blinking on the device dropped right away, but ZHA showed no difference. I was however able to manage the device now in that I could send commands to it and it replied. There isn’t any reporting going on which means I get no new readings logged.

I tried restarting HA but it changed nothing. I checked the network graph and this device is not I’m the network, i.e. there is no route to it, yet I can communicate with it via HA.

How do I make HA setup reporting on the device again? And more importantly, how do I prevent this from happening?

There is nothing between the router and the device except for a brick wall.


In my attempt to fix this problem, I tried to bind the service to the coordinator.

I am not sure if this has an effect, but the network topology updated and now shows the ZHEMI device to be routed via a mains powered devices and had 139 SNR (very high).

Still no reporting going on, though.

I used the Reconfigure button on the device and the setup binding and reporting. Reconfigure failed, though, as there is an attribute (temperature) that could not be configured. The rest was configured though.

So, steps I think are necessary when (not if, distantly) this happens again:

  1. Open join window on the coordinator (add new device). Let it time out although I think a few seconds probably are enough).
  2. Check if device responds to requests, e.g. read instantaneous demand from the metering cluster. If it doesn’t respond, you may have to wake the device manually, press a button or power cycle it
  3. Use the Reconfigure button on the device in HA.

I wish I knew why HA loses the device… That is not normal.