Device has no entities

Hello!
I recently bought kind of a weather station called “ZX-7178” which acts as a tuya device. A thermometer which measures the water temperature of my pool connects to this station. In the tuya-app (and also in the SmartHome-app) it shows severals sensors, especially air and water temperature.

I can add the device to home-assistant via smarthome-plugin, but HA tells me that this device has no entities. Any ideas how I can get these two temperatures in HA?

Hello,
yes, same device, same problem. Does anyone have a solution?
Best regards

I solved it. Switched from “Smartlife” to “localtuya” integration. When you add the device, you get entities for all temperature sensors. localtuya is a bit of pain in the a… to configure, when you do it for the first time, but after a while, you understand the logics of adding and editing a device with several entities.

Sensors give temperature in Fahrenheit, although device was set to Celsius. Had to made a template to convert. But now it works!