Device isn't responding in Alexa HA Cloud

I’m not sure is it related to HA Cloud, but sometimes when I ask Alexa to switch on/off stuffs, it will reply “Sorry, [device name] isn’t responding”. It affects every devices exposed by HA cloud. I have to restart HA to make it works again.

Is this a known issue?

I am seeming that issue if the connection dies between HASS and the HASS Cloud Service


I have encountered the same problem (‘device isn’t responding’). Thanks for breaking it down @walt.

Restarting my Pi with hassio (e.g. restarting HA) does not seem to actually resolve this (consistently) for my HA instance, which strikes me as odd. I’ve set up hassio to get itself a fixed local IP address, and although I can reach my HA instance through the DuckDNS forward, I just noticed my hassio-pi actually does not have a DHCP listing in the modem. I wonder if it’s related to @walt’s observation that the HA cloud component tries to call a local IP.

Have the same problem, either restart HA or reconnect the account on the HA configuration panel fixes the issue. Hope this gets fix on the next release.

Wrote a little shell script that I am calling from cron every hour to log off and then back on to the cloud service. For now it’s keeping my Alexa happy.

curl -k -X POST \
-H "x-ha-access: api_password" \
-H "Content-Type: application/json" \
sleep 3
curl -k -X POST \
-H "x-ha-access: api_password" \
-H "Content-Type: application/json" \
-d '{"email": "[email protected]", "password": "password"}' \

Replace api_password with your password, [email protected] and password with your home assistant cloud credentials, and hass-server with the IP or hostname of your HASS instance.


Hey @walt,

I’m really interested in trying your shell script for myself but I’m not sure where to run it from.

I’m running so I could run this as a time trigger but would this come under shell_command: in config?

This isn’t YAML right? not sure how to mix languages - HA noob

Any guidance would be much appreciated thank you :slight_smile:


It’s a shell script. You can run it from any system that can access your HASS server.

I’m running mine from a cronjob on my standard HASS server.

I’ve never used HASS.IO, but I don’t think that a script or a cronjob is as easy there – You might look through the documentation here, but it appears you can use the command_line switch to do the same thing. You could also write an automation to start the command_line switch every hour.

Looks like the cloud connection issue should be fixed in 0.61

I have version 0.63 installed and i’m still having this issued. Tried reinstalling the skill but I can’t control any devices anymore. Please help!

try login out/in again from alexa app and also from HA.
If the devices in alexa app show offline, after you have log out/in, scroll down and click discover device again.

Just started to have this issue also… tried the logout on everything no joy…

Looking at HA cloud integration it shows as connecting… the media player works fine just the switches and sensor no joy…


Same here, my devices were controllable through Alexa this morning, now, not so much.

Yuup. Me 3.

I get


Looking at shows the certificate expired today. So everyones cloud is going to be broken!

We pay for this service and they aren’t even using a proper certificate. Yes I know lets encrypt are valid certificates but what are we paying for if they are using a free one that has to be updated every 90 days only for either the update script to break or someone forgets to do it and we are in the situation we are in now and I cant turn anything on in my house without going to the GUI!

Poor service! Get this fixed ASAP.

Balloob is aware and is fixing it now.

1 Like

Yep, it was back working this morning :slight_smile: Thanks guys

i am having the same issue right now on latest versions.

has anyone else had this problem lately? i have it now on latest ve3rsion. would love some kind of fix.