Device not discovered by Z2M after being deleted

Newbie here hoping you could help with an issue I wasn’t able to fix for a week now.

I recently discovered the benefits of zigbee devices being brought together and controlled in HA. I have a bunch of them from different companies, but I had issues from the start with my Aqara roller blinds controller in HA. I have a Sonoff Zigbee Stick P as my coordinator and I originally started with ZHA as my HA platform. But there were some issues in ZHA with the Aqara blinds motor, mainly some functionality that was unsupported. So I saw somewhere that z2m might provide better compatibility.

And to be fair, I was able to get access to more features with my device with z2m, but there were other major issues, like the state of how opened the blind is not updating. And again, I read somewhere that this must be caused by old Sonoff firmware. So I embarked in the strenuous journey of updating the firmware, and, after a few headaches, I managed to do it.

After the firmware update, all my zigbee devices where still there, but my Aqara blinds had the same problem. I thought that it might be because the device should be refreshed, thinking that I might get it working properly if I delete and put it back in z2m. So I confidently went ahead and deleted the blinds, but when I wanted to pair them back into z2m, they were not being discovered.

I had other devices in there that were working fine, I even bought an Aqara zigbee button to see if I can add it in, and that worked. So my issue is that I can’t add the Aqara blinds back into z2m after being deleted. I put the blinds in pairing more, I turn z2m in pairing more too, but they don’t get discovered. I’ve tried disconnecting my raspberry pi from power, disconnect the Sonoff stick from it too and, even though that fixed the issues for others that I read had a similar issue, nothing changed for me.

Would anyone have any other suggestions? I really had big plans to get a decent zigbee network with lots of devices throughout the house, but I don’t want to keep adding and configuring devices if I’ll end up deleting or resetting them all in my attempt to get the blinds working.

Many thanks in advance,


For the zigbee device ‘deletion’ process to really work, requires the coordinator, device to be deleted and the software stack on top of the coordinator (in this case Zigbee2MQTT) to all be in communication at the time of the deletion. I’ve see this ‘can not add back’ scenario occur while failed to have all three connected (and awake in the case of some sleepy end devices). You can go in and edit the Zigbee2MQTT configuration YAML file and check and manually delete the rogue device (make sure to restart Zigbee2MQTT after changing config YAML) and hard reset the end device (sometimes hard to figure out the ‘button press’ sequence required). It is often best the get the end device full reset first before doing the ‘clean up’ and restart of the coordinator and Zigbee2MQTT end. Do a hard power cycle of the coordinator device as well as part of ‘rebooting’ Zigbee2MQTT.


  1. Shutdown Zigbee2MQTT.
  2. Power cycle the coordinator device (IMPORTANT to make sure if it is USB that it comes back at same USB location as it set in your Zigbee2MQTT configuration YAML!)
  3. Hard reset the end device.
  4. Check your Zigbee2MQTT configuration to make sure BOTH that the device’s zigbee MAC address is no longer in the configuration YAML and that you did not accidently tell Zigbee2MQTT to not allow the device back into the network.
  5. Restart Zigbee2MQTT, check it’s logs for any errors or reference to the rogue devices MAC address.
  6. Try to re add the zigbee device.

Good hunting!

maybe, you blocked them to join?