Device tracker doesn’t know where I am after restarting HA

I have device tracking set up through the HA app on my iPhone.

I have home defined, and work defined.
HA knew I was home, I restarted HASS and now it says “away”

I imagine this is something to do with it only transmitting significant movement changes so me not moving means it doesn’t locate me at home again but why does it just not know I was at home and say I still am?

Can I get round this anyway?

I use a location_update in a statup automation. Sometimes takes 10-15 sec but works for me.

  - alias: "StartUp"
    initial_state: True    
      platform: homeassistant
      event: start
      - service: notify.ios_jd_iphone
          message: "request_location_update"

Are you restarting Hass often enough for this to be a problem?

Is this using the companion app?

Well at the moment I am restarting hass most days while playing with it / trying to get anything to work so would be nice if it did pick up my location after a restart.

1 Like

Thanks. Sadly my other post is about the fact I can’t get notifications to work on my HA app but will try it anyway. Thanks.

I do use the IOS HomeAssistant app. If you don’t receive notifications something is wrong, get that going first.

Yeah that’s what I’m trying to do with these posts. Will remove the iOS line from my config and start again

added this to automations, and changed the notify line to my name

I do not see this notification pop up though or do anything and my location does not update.

I tried to add the same automation you have given using the automation GUI but got stuck with the message, is “request_location_update” JSON? Tried putting it in the serivce data box but it does not like it?

I will not tell you if you request a location update, unless you have specific notifications turned on. Under Location Setting, its one of two I dont recall “Background Fetch notifications” or “Push Location request…”

But first are are three check marks checked under settings? “iOS Compnent Loaded” , “Device Tracker Com…” and “iOS Notify…”?

yep all three are working and my IOS app has always been really good at tracking my location, I have a sensor setup to monitor my time at work each week and it works to the minute other than when I am playing with HA at work and restart it to make a change, at which point HA “forgets” I am at work and just sets me to away, hence the bit around trying to force it to update at restart.

on the location settings page in the app all the update sources are green for go, including push notification request, just wasnt sure if the app would display the “notification” or just handle it.

and I was wondering if I could manually send the request through here somehow:


OK, well sorry, I helped as much as I could. I showed you the way mine is set up and mine works. Hopefully someone else can jump in.

Cheers Jason, appreciate the help. Little things like this drive me mad, I know its open source but I think I am the main target user for v1 when it comes on, but stuff like this just seems a problem that shouldnt exist.

Thanks for your help though, I have still learned from what you put even though it hasnt solve my issue

One more comment, this seems to work fine for me… And if I turn on notifications for “Background Fetch notifications” or “Push Location request…” it notifys me an update was made.

thanks that was it I wasnt putting the message bit in the service data, didnt know you had to with a call like that. Doing it manually sends, doing it as an automation doesnt for some reason, have seen someone else saying similar automation but with a time delay so will have a play. At least the call works.

Thanks again