Device tracker not working on Android phone

Hi all.

After several days of messing around with an iPhone to get device tracker to work with an automation and finally succeeding, I now need to do the same with my partner’s Huawei android phone.

These are the things I have done

Downloaded HA companion app on her phone
set up our server on there
set her up as a ‘person’ within HA and set her phone as tracked against her name
turned on all the location sensors in the app inlcuding
Geocoded location
background location
high accuracy mode says true but tried it saying false too
high accuracy update interval 5 seconds
Location zone
single accurate location

The automation works, it’s just the device tracker is not updating when the phone leaves or enters the home zone.

I am tearing my hair out after days of doing this with an iPhone and now with Android. This should not be so hard.

Can anyone offer any help pleeeeeeae?

Thank you.

Did you ensure that the HA companion app is allowed access to location and that battery optimization is off for the app? (apps, under your phone’s settings menu)

It’s a different screen but basically I have an option of allow optimisation or don’t allow. It is set to don’t allow so it is not restricted.

I’ve done all this

  1. Ensure the app has location permissions granted, all the time. (Users on Android 12 will need to ensure Precise location is given during the prompt)
  2. Ensure that location (GPS) is enabled on your device.
  3. Turn off battery optimizations for the app.
  4. Under Configuration > Companion App > Manage Sensors ensure that the following Location Sensors are enabled: Background Location, Location Zone and Single Accurate Location
  5. Turn on unrestricted data for the Android app. (Samsung users will need to disable data saver for Home Assistant as well.)

But not this as I cannot find it

  1. Check that the background access setting shows the app has proper access under in Settings Companion App.
1 Like

The settings for the Companion App are only available if you are viewing them FROM the companion App on the device in question (so you need to do it from the companion app while on her phone as her.)

When you’re the app it’s the last item under ;Other Settings’ which is right under ‘sensors’:

I know this is quite old, but this is what worked for me. Uninstall the companion app, reinstall it and then go through setup again. Or, you can simply go into the app settings and clear the cache and data, open the app and go through setup again. The later is what worked for me.


This has worked for me also, clear the cache and cleared the data and reconfigured the companion app, with remote access.

Thx, it worked for me too.

This is interesting, I was able to get into App Configuration for Home Assistant Companion APP on my wife’s phone, but I can’t on mine.Hmm?