Device Tracker - Platform Unifi Direct no longer working since updating to 0.114.3

Since updating to 0.114.3 the device tracker no longer works. No updates, no trackers showing up, known_devices.yaml does not get created or updated.

If I run a Configuration validation it spins without completing. After that, the log file shows the following:

Logger: aiohttp.server
Source: components/unifi_direct/
First occurred: 12:03:33 PM (3 occurrences)
Last logged: 12:27:43 PM

Error handling request
Traceback (most recent call last):
File “/usr/local/lib/python3.8/site-packages/aiohttp/”, line 418, in start
resp = await task
File “/usr/local/lib/python3.8/site-packages/aiohttp/”, line 458, in _handle
resp = await handler(request)
File “/usr/local/lib/python3.8/site-packages/aiohttp/”, line 119, in impl
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/”, line 39, in real_ip_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/”, line 73, in ban_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/”, line 127, in auth_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/”, line 129, in handle
result = await result
File “/usr/src/homeassistant/homeassistant/components/config/”, line 29, in post
errors = await async_check_ha_config_file([“hass”])
File “/usr/src/homeassistant/homeassistant/”, line 857, in async_check_ha_config_file
res = await check_config.async_check_ha_config_file(hass)
File “/usr/src/homeassistant/homeassistant/helpers/”, line 164, in async_check_ha_config_file
platform = p_integration.get_platform(domain)
File “/usr/src/homeassistant/homeassistant/”, line 389, in get_platform
cache[full_name] = importlib.import_module(
File “/usr/local/lib/python3.8/importlib/”, line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1014, in _gcd_import
File “”, line 991, in _find_and_load
File “”, line 975, in _find_and_load_unlocked
File “”, line 671, in _load_unlocked
File “”, line 783, in exec_module
File “”, line 219, in _call_with_frames_removed
File “/usr/src/homeassistant/homeassistant/components/unifi_direct/”, line 5, in
from pexpect import exceptions, pxssh
File “/usr/local/lib/python3.8/site-packages/pexpect/”, line 2
IndentationError: unexpected indent

Any idea how to fix this?

1 Like

** Solved **
Restored to previous version using snapshot. Full shutdown of pi, powered on, updated again. All is working now!