Device Tracker - Sending data to Traccar

Hello everyone :wink:

if anyone is interested I have developed this simple package to send data from any device_tracker from Home Assistant to Traccar, a popular open-source GPS tracking system, already integrated in HA but from Traccar to HA.

For example, I used it to track on Traccar phones that are already being tracked with Home Assistant’s iOS/Android app, without having to install any other software that sends data to Traccar (and without exposing Traccar outside my network) and my electric scooter (Silence) integrated in HA but not on Traccar.

I think Traccar is much better than Home Assistant for storing and showing travel history data, while Home Assistant is much better for automations and everything else.

You can find the script and a very small guide on how to configure and use it here.
https://github.com/lorenzo-deluca/homeassistant-traccar

If anyone wants to participate in the project go ahead and PR at will!

Let me know what you think and if you want to add contributions :slight_smile:

1 Like

Thanks for sharing Lorenzo!
Works like a charm.
I would like to add a button with tekstbox in home assistant to send an annotation to traccar for when i see something while travelling i want to remember where approx. it is on the map.

Nice project! Works perfectly and indeed Traccar is much better at tracking history.

1 Like

Thanks, good :slight_smile:

Very interesting project!
Thinking about a possible use for myself…

Cannot get it working with a demo Traccar server.
It has “https://demo3.traccar.org/” address.

Tried this:

    url: "http://'xxx:yyy'@demo3.traccar.org:8082"

where “xxx” - login, “yyy” - password.
And in fact “xxx” - email id, “yyy” contains a “@” character.
So, the line is like

    url: "http://'[email protected]:abc@'@demo3.traccar.org:8082"

Added a device on a Traccar server:
изображение

But still the device is not updated:
изображение

Modified the automation a bit, it sends a persistent notification:

...
    action:
      - service: notify.persistent_notification
        data:
          message: virtual_tracker_1
      - service: rest_command.update_traccar
        continue_on_error: true
        data:
...

So, the notification appears when the “virtual_tracker_1” is updated, but the corr. device on Traccar - not updated…

I write it in documentation, for updates I use default protocol that runs on port 5055 :wink:
I never try on public demo Traccar server but I guarantee that on local server works :slight_smile

Let me know.

Sad, I am using a public server…

ok, so, you have to check if with default protocol (on port 5055) can be enable authentication… by default there is no authentication as I know.