Device Tracker: TP-Link Archer C3150

I have the TP-Link Archer C3150, and would like to see the TP-Link device tracker expanded to support this device.

Please and Thank You.

Did you test that router with the existing TP-Link device tracker platform? If yes, any error messages in the log?

I did test it, but it’s been about a month. I’ll test it again in the morning and report the error messages.

OK, I tested this morning, and here is what I see in the log:

16-09-08 06:10:15 homeassistant.components.device_tracker.tplink: Couldn’t fetch auth tokens!
16-09-08 06:10:15 homeassistant.components.device_tracker.tplink: Router didn’t respond with JSON. Check if credentials are correct.
16-09-08 06:10:15 homeassistant.components.device_tracker.tplink: Router didn’t respond with JSON. Check if credentials are correct.
16-09-08 06:10:15 homeassistant.components.device_tracker: Error setting up platform tplink

I also tried the instructions for the ArcherC9, and receive the following:

TypeError: document.getElementById(…) is null
TypeError: $(…) is null

I also tried to Base64Encode the password (saw reference to that within the page source):

auth = "Basic " + Base64Encoding($username.value + ":" + $password.value);
document.cookie = "Authorization=" + auth;

but that didn’t seem to work either.

I have the exact same issue with TP-link Archer C3200

I tried exactly the same as pab6969 - before reading this thread - with the same result. It would be really great if the device tracker is working with the C3150

I have a VR2800 and it’s doing the same thing.

Hi. Have you manage to solve the problem i have same router and same problem.

Unfortunately, I never did. Ended up switching to pfSense and Ubiquiti (for other reasons).

I gave up on trying to figure out how to submit an issue because I used NMAP, but it’s still broken.

Hello sir! Could you please share your situation with device tracking using the C3150? I’ve bought a couple of them and being struggling to get this to work reliably with NMAP… Thanks!

It’s ma’am, or Martha :stuck_out_tongue:

NMAP is decent, this is today and I’ve been home all day today:

Right now using multiple devices to track presence following @arsaboo 's example.

As far as setting NMAP up? I just followed the directions.

Hello again! I am so sorry, I did not knew you were a woman heheheh I’m very sorry about it…

I have a particular setup for my network: My ISP goes through a first C3150 in my office (DHCP), then I have a couple of CPE510 to bridge my internet and network to my house, connected to a switch that has another C3150 that connects all my wifi devices there. My Hassio is connected by LAN directly on the switch, at home.

My devices keep disonnecting all the time, like this:

Also, there are many errors like this on my log:

Updating device list from nmap_tracker took longer than the scheduled scan interval 0:00:12

I am about to go crazy hehehe

I’ve bought these two C3150 thinking they would fulfill all my needs regarding Wifi network.

Thanks for your information!

I’ve just rebooted the host (using Hassio) and now all devices seems to be detected. It might be something to do with the docker or how NMAP access the network inside the container…