Device trackers always showing not_home despite being used

Device trackers always showing not_home despite being used and should be showing home. This used to work but something has changed. The only ones that work are the ones I use in the Person entity.

How do I get old behaviour back?

1 Like

I don’t know. You haven’t given any information other than you have device trackers.
How do you expect us to help you?

1 Like

looking for people with same issue to perhaps collaborate. Do you just go around trolling nonsense to make yourself feel better somehow? Feel sorry for you mate.

Not trying to troll, genuinely want to be helpful.
But to get a proper response from people we need information.

What device trackers work? What device trackers don’t? What device trackers are part of your person entities? What version of HA are you on? When did they stop working?
When you say using “using” the device trackers, what does that mean? Are they phones? Bluetooth devices? Etc. Etc.

I’d rather reply and get more information from you than just leave it and for you to get no replies.


Good luck finding help with an attitude like this…


Good to know you could help if only people would submit and act how you like. Thanks for chiming in.

Alrighty, sorry Andy, I know I was vague but my limited experience suggests to me that this is an issue of reporting on device trackers being changed by design as everything worked perfectly, I lost connectivity of my installation for 3 weeks, then when I restored on a fresh install I noticed this.

And when I say "using device_trackers: I simply mean that they used to report Home or Away, now they all report Away 24/7

Supervisor ver 2020.11.0
HassOS 4.15 on a R Pi 4+ 32 GB
HA Core: 0117.2

Here is a screenshot of my UI with this tab showing all device trackers,
in the center column you will see Mark, my person entity showing me Home and the mobile APP showing me Home. These are 1 and the same as my Person entity only uses that 1 device tracker, the mobile app.

On the right column there is 1 Bluetooth device showing Home, ignore that, it never reported correct. The other bluetooth device that likely cant be seen report correctly. The issue seems to be wifi or LAN connected devices. I use the R Pi on a wired LAN, not wifi.

Here is my device_trackers.yaml…

  - platform: nmap_tracker
      track_new_devices: true
#      hide_if_away: false      
    interval_seconds: 10
#  - platform: ping
#    hosts:
#      host_phone_ping:
  - platform: bluetooth_tracker  
    request_rssi: true        

  - platform: bluetooth_le_tracker

You know there’s something called forum guidelines? Ever heard of it? Please read them here.

Your initial post is as useful as “my car broke, it used to drive, now it doesn’t”. Then you accuse the first person that answers you as a troll.


Ok, that is strange. Would look like a problem with the nmap_tracker though.

Your ‘hosts’ don’t seem to be in a list (with dashes -) and I don’t see ‘new_device_defaults’ or ‘interval_seconds’ as options in the documentation.

Can you try replacing the nmap_tracker yaml with this:

  - platform: nmap_tracker

Let me know how you get on.

1 Like

I use nmap only for monitoring specific devices on my network (eg some PC online to turn on/off specific printer etc.) and it works fine (now on 117.4) :slight_smile:

  - platform: nmap_tracker
    home_interval: 1
    hosts: 192.168.1.xx
    scan_options: " --privileged -sn "  

Best, JR

PS for scan_options see Docs!!

1 Like

You probably have errors in the log like this:

Updating device list from legacy took longer than the scheduled scan interval?

There’s an ongoing issue with nmap in regards to scanning ranges of IP address, see this issue that has been open for over a year.

1 Like

Hi Andy, I amended as you suggest (except as and it works again. Thank you for your assistance!

Thanks, I will look into this but the issue was just resolved. Appreciate the feedback.

Thank you for your response!

Hi Andy, the device trackers have reverted BACK to previos non working behaviour.

Going to look into the issues that Burningstone reported…

yes, this is exactly it. The trackers worked for a few minutes after restarting , then back to old non working behaviour. I amended as per the article, we"ll see how it goes.

Thank you, sorry we dont get along, your a good person for helping regardless. Cheers.

1 Like

I’ll give this a go. Tried about 5 different things now, it just seems like Nmap on HA is broke and no one wants to say it lol.

On the bright side, I noticed my UI is way faster now, I think the scanning and error logging was really affecting the system. I had recently had a SD card fail on a R Pi 3B+ and upgraded to a R Pi 4 and have been disappointed in how slow it has been but never looked into it much as it seemed like no one else was experiencing slowness…and as it turns out , since then I just havent spent as much time on my HA installtion because its getting annoying constantly fixing stuff. Also might have something to do with yet another sd card failure on my R Pi 4 that happened after just 3 months.

Really wish it would be taken down and people advised that its fundamentally broke and no one wants to fix it. No big deal, I’d remove and move on. Anyways, thanks.

Just out of curiosity (which I know killed the cat…) but why is it needed to scan network for tracking devices which You defined already in frontend (dashboard)? I myself track only known devices which are with static IP in my home network- so no scans needed. Maybe disabling DHCP/ assigning static IP helps? BTW I am running nmap tracker on 8 devices and haven’t had a issue on my humble Pi3+ for years… Differences may kick in as I run core (venv) and maybe Linux capabilities is what has saved me :slight_smile: Sorry but have not dug into another 3 install options of HA- I like to control…
Best, JR
BTW I saw one of Your trackers is “Mark Note 8 cell wifi” - and seems You have installed HA app - but this is HA companion app sensor to use for that - with all bells and whistles :slight_smile:

I dunno, I only do this in last 3 years as a hobby, no programming experience but have been able to learn tidbits here and there. I do have most important connections as static IPs…yes the WIFI tracker is redundant, the HA companion app works great and has a load of sensors!

I will likely look at your advice and only monitor chosen devices or use the PING tracker, I dunno. Cheers!