Device tracking broken. Need help

I had device tracker: tplink (my access point) working for me for months. Before that I had Nmap tracker also working but was bit slow to detect status change. I have written several automatons to trigger based on family group is home or away. They were all working correct.

I last checked these to be working say 0.73 and now I am on 0.762 and the status is not updating when my phone is not on wifi etc and contnue to show as HOME. I checked with Nmap too (to eliminate that is is not something wrong with tplink component but same result. How I noted is that my automations to turn off lights if family is away has not worked and started the investigation. I have no errors in the log file and home assistant info. I restarted HA several times and updated from 0.75.3 to 0.76.2 today to see if 0.75 on is broken, Not sure when it was broken as most of my automations run if I am at home and only one run when away but home assistant now shows as I am home when my phone is not connected to network too.

Are there any breaking changes for device tracking via routers and nmap?

See log below

2018-08-29 21:19:23 WARNING (MainThread) [homeassistant.config] Incomplete core configuration. Auto detected elevation: 15
2018-08-29 21:19:30 WARNING (MainThread) [homeassistant.components.http] You have been advised to set http.api_password.
2018-08-29 21:19:35 WARNING (MainThread) [homeassistant.loader] You are using a custom component for sensor.broadlink_s1c which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2018-08-29 21:19:47 WARNING (MainThread) [homeassistant.setup] Setup of config is taking over 10 seconds.

What sort of phone do you have? A recent iOS update on my iPhone (11.4.1) made the previously reliable nmap tracker unusable.

iphone 7 plus is the one causing issues. Other phone is note 5 and it work ok