"Device was added insecurely" - Aeotec sensor

HA noob here (sorry…).

I had a messed-up HA installation and so i rebuilt it, nice and clean - 2022.2.1.

Added my Nortek Zigbee/ZWave USB hub. The Zigbee portion added fine; the ZWave asked me for a key but said it would generate one if left empty, so that’s what I did. (Since then have viewed the zwave config file and confirmed that there are keys in there.)

Added first device: ZWave Aeotec temp sesor: got the above error message. I’ve since deleted, readded, deleted the hub, readded it, restarted etc…no change.

Added second device: Fibaro water sensor. Worked in seconds. No issue at all.

Back to the Aeotec…I do remember that when I set it up the last time (albeIt in a 2021.x version) it forced me to enter a 5-digit key as a Device Specific Key. This time it did not do so…which is (presumably) why the error message above.

So, how do I fix this? Really trying to get going with this project and can’t get out of the starting blocks…sigh. Thanks in advance.

First, its not you. Its this dang sensor!

I am on my 3rd one of these things and they ALL do this nonsense. Somehow, miraculously I got the battery on one to report correctly but the other two still don’t but after removing them and readding them 23 times, the behavior you’re describing is consistent with my experience and this is how many tries later, I have overcome it.

First, go ahead and wipe the sensor out. Hold the action button for 15 seconds, wait for the 4 red flashes, let go, blue blight then 4 more red flashes to indicate factory reset is complete.

Now start zwave discovery (without the sensor in pairing mode). Select how you’d like to connect in HA. There will be 3 options. The secure one is the one that will require the code from the back cover. There are two other ways to connect that are insecure and less secure and neither require a code. Depending on what you have set, and the fallback, it may only connect insecurely. Once you make a selection and start the discovery, press the action button on the sensor once.

My advice is to get as close to your zstick as possible. This seems to help with the secure connection I’m guessing because its more information and if it can’t get it all easily fast, you get timeouts or the insecure connection as a fallback. With this combination, it should force the secure connection.

Once you get the secure connection, put the sensor down next to your z stick and don’t touch it for 24 hours. I know this sounds bonkers but I read it on a blog or something a few weeks ago (I just spent 20 mins looking for it) and it was another user with the same frustration and the same reported symptoms.

I will be darned, every time I followed those exact steps and left it alone for 24 hours, the sensors would eventually populate completely and correctly (sometimes needing an HA reboot if the temp is 100 degrees off). This was a solution I repeated MULTIPLE times for the problem you’re describing that I also had multiple times. I hope it helps for you too. I know they can be a PITA.

I had similar issue with some Aeotec sensors. Exclude and include again finally worked. With some I had to repeat that even three, four times, until it finally got included the right way…

Patience helps in this matter :slight_smile:

@Sergeantpup Thanks! That worked. I guess, like you I’m a dog with a bone and won’t quit. 17 tries. I did eventually totally reset the device somehow bumbled through an “exclusion” (whatever that is) and managed to get the sensor up and running. This time I ran a backup…


1 Like

Glad it helped. Is the battery reporting correctly?

I finally gave up on two of them but its driving me crazy that it started working on the newest one.

1 Like

Yes, I’ve managed to (again) bumble my way to adding it as a “card” with a nice pretty green indicator. Took me a while…now I have to figure out how to get both sensors onto the same card…it’s a slow process, but I also managed to send myself a message to my iPhone last night.