Devices disappeared in Z2M gui

I have two installations of HA and Z2M. One at home and one at my summer cabin.

It has been great since I moved from ZHA to Z2M one year ago.

But now, I have a problem at the summer cabin, no devices show up in the Z2M panel.
Not in Devices nor Dashboard.

Looking in logs it looks like all devices are published and they all work.
I have not run it locally, since I have not bin there.
Could this be due to a poor internet connection, it’s a mobile broadband.
Sometimes I have a speed under 1 Mbps, seldom over 4 Mbps.

Any ideas wht to look for?

Went to the cabin earlier today.
Same thing when connected locally.
Restarted both HA and router, no success…’
Tested speed with, over 20 mbps!!! Never happened before!
Tried various restart combinations.
Then I shutdown HA, made it powerless for 15 seconds, before connecting the power again.
One device showed up. Couldn’t connect via Nabu Casa.
Shut down both HA and router, with power off for a minute. Then it worked.
But still, external access didn’t work. Had to leave. When I came home the external access also worked…
Very strange I think the ISP is to blame here, but still it should have worked locally…