Devices shown offline in cable connected ESPHome

Anyone else face this behaviour?
If I run ESPHome from my Wifi-connected Labtop (Lubuntu 18.04), my NodeMCU an Wemos D1 mini are online and stable. I can edit and upload firmware.
But, if I install ESPHome an a Ethernet connected device (Raspian, Luntuntu, on a Raspberry) my ESP8266 modules have a very unstable online status. Usually they are online for a few seconds, then they turn to red and are markes as offline…

Could “WiFi” vs. “Ethernet” be the reason??
I don’t actually believe in it, but I can’t think of another answer at the moment.
Any ideas?

Wifi vs wired is no problem. My esphome computer is wired.

Hmm, it’s a mystery for me… I have tried several ESPHome installations like Lubuntu on a physical machine, on a virtual machine, hassio Add-On in a virtual machine and Add-On on a Raspberry Pi, but the only working one is my Lubuntu on a Thinkpad with Wi-Fi connection…

Anyway, for now I can life with it, but it’s stange anyway…