Devolo thermostat

Will i be able to use the below thermostat from devolo with home assistant without the need for devolo home central hub?
I have a zwave usb stick to pair it with

1 Like

I am also interested in that thermostat because I am looking for a zwave controllable one. There are not much choices though (Danfoss does not expose the current temperature according to Danfoss Living Connect Z thermostat - no temp sensor readings? and the Eurotronic one is ugly).
So does that Devolo thingy work with HA and are we able to read the current temperature?


Since it’s basically a rebranded Danfoss, I don’t think it will behave any differently.


You are basically right, but I’ve read somewhere that Devolo is using its own firmware which is slightly different from the Danfoss one … (German source: “Obwohl der Fühler im Thermostat selbst sitzt. Jetzt kommt aber ein dicker Hacken: in den Genuss dieser internen Messung kommen nur Nutzer die sich für die Devolo-Variante entscheiden. Denn die Firmware wurde im Fall von Devolo so abgeändert, dass die gemessene Temperatur des Thermostats auch an die Basis gemeldet wird. Das Danfoss Modell hingegen nutzt diese interne Messung zwar um das Erreichen der gewünschten Temperatur sicher zu stellen – die Basis bekommt diese Info jedoch nicht.”)
Seems as if I have to try that in case nobody tried it before …

It would be great if you’d let us know how it went :slight_smile:
I’ve seen a review on that claimed the current actual temperature is available through the device, even when not using the Devolo base station.
So you might be lucky.


I also have the Devolo with the temperature showing, just need some tweaking in the zwconfigxxxxxx.xml.
Stop Zwave service and add the following lines in the xml

		<CommandClass id="49" name="COMMAND_CLASS_SENSOR_MULTILEVEL" version="6" innif="true">
			<Instance index="1" />
			<Value type="decimal" genre="user" instance="1" index="1" label="Temperature" units="C" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="18.47" />

Save the file and start the zwave service again.
When the device awakes you should see the current temperature.


It took a while until I found some time to add the Devolo thermostat to HASS … I just added it and it worked right out of the box. No manual tweaking needed at all (zwconfig*.xml) and the temperature shows up.


Could you tell us which model did you buy?

I am not aware of different models from Devolo. Isn’t there just one model?

Hey, I’m new to HA and I am thinking about buying this devolo thermostat. I see you are using it since May 17…can you recommend it? Does it work fine with HA out of the box with all functionality or do I have to change config files or something else?

It just works. Nothing more and nothing less. But that’s basically all it can do though :wink:
Battery is at 40% right now.
It worked out of the box without having to modify any zwave stuff manually.

Ok, thanks for your reply. For me as a beginner is it partially difficult to find devices which are already supported by HA.

I can confirm, everything works out of the box. Add device in HA and push the function key on the thermostat and you can control it right away and read the temperature.

@Appieland, I tried your suggestion (to add the extra CommandClass element in order to get the current temp) but it doesn’t seem to work for me. I do see a current temperature now for my thermostat but it never changes. It stays at 18.5, which I guess is the value attribute preset in the xml.

Does this really work for you? Is there perhaps anything else I need to do?

For me it is working, also the history graph shows the change in temperature and is updated as soon the temperature changes in the “sensor.danfoss_devolo_home_control_radiator_thermostat_temperature” .
In the XML i added the lines above the <CommandClass id=“67” name=“COMMAND_CLASS_THERMOSTAT_SETPOINT”

That’s exactly what I put it too. Perhaps the problem is that I have the danfoss version and not the devolo.

The Danfoss LC TVR does not have the temperature sensor.
For this reason i bought the Devolo TVR.

Does this Devolo thermostat shows in attributes valve position. I mean how much is valve open. Thanks

It does not expose the valve position.

I’m using both, Danfoss and Devolo devices and can confirm that only the Devolos return the sensor temperature. Both don’t show valve position.

I have another issue however. In neither devices I have any z-wave config parameters available. In other devices with temperature sensor (e.g. Fibaro smoke sensors) I can set a temperature change threshold which leads to a transmission of the new value to the homebase. I think it should be there, since I remember changing it on another platform (domoticz), but there just isn’t anything available in my home assistant z-wave config. Can anyone confirm this or even help?