Dexcom- not available

A few days ago, I changed the password to my account. I expected Home Assistant to lose connection and become “Unavailable”. No problem, just update the password on the Dexcom configuration.

Problem… I can’t find how to do this. Where are the Dexcom login credentials stored?

Temporary solution- change the password back to the original. But, the Dexcom sensor is still “unable”.

Help would be appreciated.

You should find it in


The ONE place I didn’t look in. I was under the impression that .storage files were off-limits to user tinkering?

But after fixing the password in core.config_entries and restarting HA, everything works again.

Please mark the solution

It’s supposed to be off limits, but some integrations were migrated to UI without proper thinking, and do not allow basic capabilities such as changing user/password or API keys.

The “proper” way is to remove and reinstall the integration, but hey, are we tinkerers or are we not :wink:

That was going to be my next step. And, yes this was a custom integration until a few months ago when it became an official component.

I know this is an old thread, but I am experiencing the same issue. I can’t seem to locate my storage folder. Do you have any suggestions?

It is a hidden folder named .storage in the config folder.

thanks…total noob question here, but how do I unhide it so that I can update my dexcom password?

Interesting question. I am guessing that you are using the File Editor add-on. Until you asked, I did not know that the editor add-on does not expose hidden files or folders. And I don’t see a way to change that.

I use the Samba add-on and do all my editing on my PC. The PC doesn’t recognize the Linux method of hiding files or folders by starting the name with a dot, so my editor on the PC has no problem opening it.

I am actually using Studio code server but I will try adding the Samba add-on

I never use Studio Code Server - too complex. I just use Notepad++ on my PC. After installing the Samba Share add-on, you should see this on your PC’s File Manager:


thank you for trying to help. I installed it but I can’t locate it on my PC. Is deleting the dexcom integration and reinstalling it an option? I’m worried I am going to lose all of my custom automations if I delete it

Is the PC is on the same local network as the Home Assistant server?

Here is a video of how to set up Samba Share.

If you really want to use Studio Editor, I found a way to make the .storage folder visible:

Open the editor.
Open Settings:

Click on Text Editor
Click on Files
Scroll down to "Exclude"
Delete the line: 

!thank you! I got it to work with Samba and found the hidden storage folder!