Diagnosing whats blocking Google's local fulfillment?

Hi all

So i run HA in VM form through the KVM plugin on my Open Media Vault 6 server.

The VM has its own IP address on the network via a macvtap interface.

Everything works great, except for the life of me i just can not get local fulfillment to work with my google devices.

I used too have HA installed on a different box with lower specs, but it was a non-supported supervised install, local fulfillment worked great. When i upgraded my machine i decided to keep HA clean and use the VM (where i pull in the backup of my existing system and sent it on its way). Everything is the same between the 2 installs (addons/settings wise, i was using DuckDNS for my nginx proxy but have since switched to a the Dynu dns provider and the corresponding plugin in the hopes it was an issue with DuckDNS, but it wasn’t)

I’m not really sure how to diagnose this issue, i don’t see anything in any logs i’ve looked at and not really sure where to find anything on googles side (ie through their cloud platform or whatever).

Would really like to get local fulfillment working, my latency to googles cloud can be so bad sometimes i can ask google to turn on a light and it’ll be 10+ seconds till it goes through, enough time for me to ask it again even though its just a delay via the cloud…

What’s the status of this endeavor? There’s a google chrome debug tool in the documentation. Additionally, you can look to see if it is working with this latency graph.

If you have multiple VLANs consider Avahi