Dialogflow on v.0.83.3

I’m trying to configure DialogFlow but without success. https is well configured and working.

The documentation is misleading and not complete.
It’s written to add to DialogFlow fullfitment:

  • Enable Webhook and set your Dialogflow webhook url as the endpoint, e.g., https://myhome.duckdns.org:8123/api/webhook/800b4cb4d27d078a8871656a90854a292651b20635685f8ea23ddb7a09e8b417

but where have I to put this webhook_id in my configuration file?
Looking in source files there is an “webhook_id” so i tried to add (with this ID just for test)

  webhook_id: "800b4cb4d27d078a8871656a90854a292651b20635685f8ea23ddb7a09e8b417"

but the answer was “(MainThread) [homeassistant.components.webhook] Received message for unregistered webhook 800b4cb4d27d078a8871656a90854a292651b20635685f8ea23ddb7a09e8b417”

“status”: {
“code”: 206,
“errorType”: “partial_content”,
“errorDetails”: “Webhook call failed. Error: Webhook response was empty.”

Looking on forums I’ve fould other URLs so I tried to changed with

and the is always
“status”: {
“code”: 206,
“errorType”: “partial_content”,
“errorDetails”: “Webhook call failed. Error: 404 Not Found”

Which is the right configuration?
Anyone has a working example?


Not sure if you got this working or not?

To use webhooks in Dialogflow, you should use Long Lived Token for security access and set DF agent to version V1, V2 is not yet supported…

In the fulfillment section of DF, the following is required:

URL:    https://Your_domain.duckdns.org/api/webhook/Your_web_hook_id
Headers:    Authorization    Bearer Your_long_lived_access_token
            Content-Type     application/json  
DOMAINS:    Enable webhook for all domains

I have a working project using this method linking Google Home / Assistant to HA for control of media players. see https://github.com/ynot123/LMS_Controls for further details.


thanks for highlighting this. took me awhile to find this solution.

Anyway, just wanna add that there is no need to key in anything in the Headers section, only the Webhook URL that is generated from HA frontend > Configuration > Integrations > Dialogflow.

May I know do you integrate Telegram in the DF?