Dialogflow set up not working


I’m currently trying to set up Dialogflow to work with Home Assistant and later the Test version of my Google Home / Assistant app.

I followed the instructions on the component page for the set up, but it seems that it is not working.
When opening the API URL in the Browser i get a Error 405: Method not allowed which should be OK in my opinion, as the API only allows POST requests(?)
This is my HA URL: https://raspberrypi.XXXX.myfritz.net:8123/api/dialogflow/?api_password=XXXXX
It is only accessible via IPV6 but it works for the Google Assistant component and is successfully linked to a Google Home.

The action for my intent is called SetMusicBose and is supposed to change the input of media play to my Bose Sound system.

The JSON response from Dialogflow looks like this

"status": {
  "code": 206,
  "errorType": "partial_content",
  "errorDetails": "Webhook call failed. Error: Webhook response was empty.",
  "webhookTimedOut": false `

While I created the Dialogflow project I linked the new project to my existing Assistant project. Currently it is NOT using Dialogflow V2 API.

my configuration.yaml looks like this

      text: Ok, changing input
      service: media_player.select_source
        entity_id: media_player.BOSE

I already added the KEY / VALUE pair to the HEADERS in Dialogflow but it did not help.

What did I do wrong? I cannot figure it out and a google search has not brought up anything new.


Hi rcma

You got it working ?

no still no luck, but during the last days I didn’t try due to time issues.
I will probably try again during the weekend.
Right now my complete Google Assistant / Actions on Assistant setup is broken too, so I have a lot to fix :smile:

Oooh :smiley:

Well can you help me on this.

When i’m hitting my home assistant URL something like https://myhome.duckdns.org/api/dialogflow?api_password=HA_PASSWORD

I’m getting error 404

and my DialogFlow response is also showing me 404 errro obviusly because it could find the URL, any suggestion ?

“status”: {
“code”: 206,
“errorType”: “partial_content”,
“errorDetails”: “Webhook call failed. Error: 404 Not Found”,
“webhookTimedOut”: false

Stupid me Did’nt included the line dialogflow: line in configurations.yaml file :expressionless:

Added it and it’s giving 405 :slight_smile:

did you manage to get the setup working? I’m always getting the error in the first post and cannot connect.
I even deleted everything and reconfigured the whole system (Google Assistant + Dialogflow) but nothing did change

I’m also having a similar issue.

text: The temperature is {{ states(“sensor.hallway_thermostat_nest_temperature”)}} degrees in your home.

  • In Dialogflow website, I’ve created an action with name: “TempIntent”.
  • Fulfillment is set to my HA address. I’ve tried adding x-ha-access in header, as well as Content-Type.

Have I missed anything?

I tried exactly the same steps.
Do you have an IPv6 Adress behind your DuckDNS or whatever you are using? Right now I think it might be related to an IPv4 <-> IPv6 compatibility issue.

So, DHCPv6 was already disabled on my router, but I disabled IPv6 on the machine anyway according to this guide. I’m using Centos 7 for reference. Sadly, no change. :frowning:

Same problem here!
Any news?

Sadly, no. I also posted on the Reddit and haven’t received a reply either.


Same problem here :confused:

dang i’m experiencing this issue as well trying to setup dialog flow, i wonder if something hasn’t changed and thus docs are out of date as i’d really like to get this working as i removed alexa from my room

Same problem here

"webhookStatus": {
  "code": 13,
  "message": "Webhook call failed. Error: 500 Internal Server Error"

I found the problem, my agent was using the API V2 instead of the V1. Changing to the V1 everything works as expected.

I’ll open an issue on github to see if there is plan to extend the support to the API V2 for Dialogflow :smiley:

Edit: issue opened https://github.com/home-assistant/home-assistant/issues/14343



Did you manage to get this working?
I’ve nearly the same setup as your Reddit post but I’m not able to get this working.
Receiving error 403 forbidden in Dialogflow Console when using the V1 API
When trying the default V2 API I receive a 401 error Unauthorized?

Configuration on Dialogflow.com:

  • Created a new agent
  • Created an intent, no context, no events
  • Created the training phrase: “What is the temperature?”
  • Action and parameters- under Action Name I wrote: “GetTemperature”. Nothing in the “parameters” section.
  • Responses: “Cannot connect to Home Assistant or it’s taking too long.”
  • Fulfillment (in the intent section): Enabled Webhook call for this event. Disabled webhook call for during slot filling

Under the Fulfillment section:

  • Enabled Webhook
  • URL: https://homeassitant.duckdns.com/api/dialogflow?api_password=legacy api password for HA
  • Basic auth empty

In Config.yaml

        text: The temperature in the bedroom is {{ states('sensor.bedroom_temp') }} degrees