Did ESPHome 2023.3.0 kill RP2040?

Hi,

after upgrading ESPHome to 2023.3.0, my Pico W stopped working. It doesn’t connect to the wifi and I get no logs on the USB serial port. The only way to get any output from it is to turn on UART logging. Which shows this:

[I][logger:258]: Log initialized
[C][ota:469]: There have been 0 suspected unsuccessful boot attempts.
[D][rp2040.preferences:117]: Saving preferences to flash...
[I][logger:258]: Log initialized
[C][ota:469]: There have been 0 suspected unsuccessful boot attempts.
[D][rp2040.preferences:117]: Saving preferences to flash...

My config looks like this:

esphome:
  name: "pico-dht22"
  on_boot:
    then:
     - logger.log: "Startar!"

rp2040:
  board: rpipicow
  framework:
    # Required until https://github.com/platformio/platform-raspberrypi/pull/36 is merged
    platform_version: https://github.com/maxgerhardt/platform-raspberrypi.git

# Enable logging
logger:
  level: VERY_VERBOSE
  hardware_uart: UART0

# Enable Home Assistant API
api:
  encryption:
    key: "secret"

ota:
  password: "secret"

sensor:
  - platform: dht
    model: AM2302
    pin: GPIO17
    temperature:
      name: "Temperatur vardagsrum (DHT22)"
    humidity:
      name: "Luftfuktighet vardagsrum (DHT22)"
      accuracy_decimals: 1
    update_interval: 10s
 

wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password

  # Enable fallback hotspot in case wifi connection fails
  ap:
    ssid: "Pico-Ds18B20 Fallback Hotspot"
    password: "somethingelse"

I have tried commenting out all the dht22 stuff, same result.

Same thing here. After the update my pico-w nodes will not connect to wifi. I had to reflash them with the older firmware (2023.2.4) of which I have backup for every node and now they work.

Asking around groups on Facebook, it seems that not only rpi pico-w has issues.

It baffles me that they don’t run it on a tiny fleet of devices before mergung it into the main branch :confused:

Could even be automated. Make it run x integrations, flash, wait until connect, rinse and repeat. If most critical pass, merge.

Yep, had the same issue when upgrading to 2023.3.0. Have rolled back to 2023.2.4.
I have 3 pico-w nodes, but luckily had only updated 1 of them… still painful to restore.

Be good to know if this is a bug or if PICO-W has indeed been killed off.

I assume it’s a bug. If it had been killed off I assume the code would be gone and it wouldn’t even compile. After all, it logs to the UART if you enable it.

BTW, how do you roll back? I tried to reinstall 2023.2.4 from a backup but got various “No such file or directory” errors when I tried to build the binary to be installed on the Pico. Or did you simply have a 2023.2.4 binary you could copy to your Pico?

I’d like rollback information as well.

I don’t have any RP2040s but, after the update and after a full reboot, non of my devices show in the Esphome side tab.

I’ve been struggling with this all day, after you have restored back to 2023.2.4, you need to clean the build files before you can compile and install again. Not only did 2023.3.0 stop the RP2040 from connecting and entering a boot loop, it stopped the wireless OTA update, will not go above at 2%-3% when updating!!!

I rolled back by changing the ESPhome docker repo from “esphome/esphome” to “esphome/esphome:2023.2.4” then deploy again. Your config files should remain in place and all show work again. In the ESPhome gui your devices then show an “update” meanwhile its a downgrade back to 2023.2.4

If anyone missed it, ESPHome 2023.3.1 is here, and it fixed the issue, at least for me.

Hello, as I have described in the ESPHome issues

https://github.com/esphome/issues/issues/4235

my Pico W is now ‘gone’ for days. It does no reconnect after updating it by USB, no logs, no signal, nothing. But I have to say, it never has been very reliable.

sorted after latest esphome update. all my picoW are back online. it seems that the previous update put the picoW in a bootloop.

1 Like

Go! Be part of it! Get involved and set the test up :wink: