Did I brick my Atom S3 Lite?

After using some Atom Lite as both Bluetooth Proxy and Heat Pump controller I recently bought a Atom S3 Lite. I tried to copy these two previous projects (one at a time) into a new project and modified the board type and compiled. After trying to load the binary with ESPHome webtool and looking at the log I saw that it was just looping. Unfortunately I didn’t save the output :sleepy: I tried to copy some other old project with the same result. It looks like ESPHome is downloading but its finished quite quickly.

Finally I tried to get out of the loop by pressing the reset button for some seconds and the looping stopped. Then I tried to load a binary again and after that I always get the following output in the log:

[15:24:43]Build:Mar 27 2021
[15:24:43]rst:0x15 (USB_UART_CHIP_RESET),boot:0x20 (DOWNLOAD(USB/UART0))
[15:24:43]Saved PC:0x40041a76
[15:24:43]waiting for download

Am I doing something wrong or is the device broken?

I google the error you receive and landed here

Basically suggests trying jtag

I would read through this first however. Don’t know if you just guessed how to reset or did from memory. Just in case something was missed I would read through reset instructions and carefully pay attention to notes and cautions. That page has full recovery instructions I believe so whatever the issue I think answer will be there

Thank you for your reply!

I don’t like the idea of bringing in separate JTAG tools that wasn’t needed with my previous ESP32-based devices, but maybe that is the only way to get it running again.

I have also google a bit and have seen that there are many problems loading programs from both ESPHome Web tool and from Arduno tools.

What worries me is the description in this link. There is a “private patch” to Espressif’s esptools but quite old. The issue is still open after two years. I will try that solution.

There is also a description of a similar problem in this thread AtomS3 Lite Programming - #35 by wbarber691. I have not managed to program the device via the local USB as described there. Maybe because it has ended up in the wrong state as described here? From that description it also states that OTA updates are not supported either. Not so good.

Regarding how I reset the device, I just pressed the reset-button on the side of the M5Stack AtomS3 Lite for > 2s according to the diagram on the device. It shouldn’t brick the device by just pressing a button…

I feel that the best is to avoid S3-products and stick to the original ESP32 until it works as flawless as before. May be due to my lack of “research” before programing, but I am not alone.